java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4... at android.view.ViewGroup.updateViewLayout(ViewGroup.java)

VERIFIED FIXED in Firefox 13

Status

()

Firefox for Android
General
P1
critical
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: kbrosnan, Assigned: snorp)

Tracking

({crash, reproducible, topcrash})

Trunk
Firefox 14
ARM
Android
crash, reproducible, topcrash
Points:
---

Firefox Tracking Flags

(firefox13 fixed, firefox14 verified, firefox15 verified, blocking-fennec1.0 +)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-2b1d53e7-d0ea-4e82-a21b-3e6662120202 .
============================================================= 

Someone with stack access please post it in this bug.
java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560
	at android.view.ViewGroup.updateViewLayout(ViewGroup.java:1968)
	at org.mozilla.gecko.GeckoApp.repositionPluginViews(GeckoApp.java:1492)
	at org.mozilla.gecko.GeckoApp.repositionPluginViews(GeckoApp.java:1475)
	at org.mozilla.gecko.gfx.LayerController$2.run(LayerController.java:269)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:150)
	at org.mozilla.gecko.GeckoApp$32.run(GeckoApp.java:1670)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:150)
	at android.app.ActivityThread.main(ActivityThread.java:4293)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:849)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:607)
	at dalvik.system.NativeStart.main(Native Method)
URL used : http://www.planet3ds.de/news/14480-kid-icarus-uprising-trailer-zum-hoellenkessel.html

Only one crash listed so far.
Seems like there's another crash that is the same but at a different address:
https://crash-stats.mozilla.com/report/index/9f7e122f-99f8-46b6-bbc1-f4f462120202
w/ url : http://www.weather.com
on a kindle fire

java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@40567478
	at android.view.ViewGroup.updateViewLayout(ViewGroup.java:1882)
	at org.mozilla.gecko.GeckoApp.repositionPluginViews(GeckoApp.java:1492)
	at org.mozilla.gecko.GeckoApp.repositionPluginViews(GeckoApp.java:1475)
	at org.mozilla.gecko.gfx.LayerController$2.run(LayerController.java:269)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:130)
	at org.mozilla.gecko.GeckoApp$32.run(GeckoApp.java:1670)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:130)
	at android.app.ActivityThread.main(ActivityThread.java:3683)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:850)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:608)
	at dalvik.system.NativeStart.main(Native Method)

Updated

6 years ago
Whiteboard: [native-crash]
Created bug 726385 in regards to trying to combine all the same crashes with different addresses.
Crash Signature: [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] → [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.Abs…
Crash Signature: [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.Abs… → [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.Abs…
Crash Signature: [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.Abs… → [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.Abs…

Updated

6 years ago
Depends on: 726385

Comment 5

6 years ago
There are about 8 crashes per build making it #1 top crasher.
Keywords: topcrash
Summary: crash java [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java) ] → java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4... at android.view.ViewGroup.updateViewLayout(ViewGroup.java)
Crash Signature: [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.Abs… → [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.Abs…

Updated

6 years ago
Priority: -- → P1

Updated

6 years ago
tracking-fennec: ? → ---
Java crash; nom-ing for blocking fennec
blocking-fennec1.0: --- → ?
Crash Signature: android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4053eb98 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalA… → android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4053eb98 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalA…
I hit this crash last evening on my Photon - https://crash-stats.mozilla.com/report/index/bp-67d89ba5-d70e-4ba2-9dcb-882342120228 but I haven't been able to reproduce yet.
Crash Signature: [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.Abs… → [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.Abs…
blocking based on being the #1 top crasher, let's get STR for it though
blocking-fennec1.0: ? → +
Whiteboard: [native-crash] → [native-crash], str-wanted, qa+
Last 30 days:
https://crash-stats.mozilla.com/query/query?product=FennecAndroid&version=ALL%3AALL&range_value=30&range_unit=days&date=03%2F07%2F2012+01%3A31%3A45&query_search=signature&query_type=contains&query=java.lang.IllegalArgumentException%3A+Given+view+not+a+child+of+android.widget.AbsoluteLayout&reason=&build_id=&process_type=any&hang_type=any&do_query=1

Last week : 55 crashes:
https://crash-stats.mozilla.com/query/query?product=FennecAndroid&version=ALL%3AALL&range_value=1&range_unit=weeks&date=03%2F07%2F2012+01%3A32%3A49&query_search=signature&query_type=contains&query=java.lang.IllegalArgumentException%3A+Given+view+not+a+child+of+android.widget.AbsoluteLayout&reason=&build_id=&process_type=any&hang_type=any&do_query=1

some more URL 
http://www.marketwatch.com/ from Mar 05, 2012 21:58 
http://www.yahoo.co.jp/ from 2012-03-05 15:09:19
http://www.clarin.com/ from 2012-03-01 22:50:36 build id : 20120301031135
about:addons - on 2012-03-03 12:04:37 with 20120302031112
http://www2.youm7.com/default.asp on 2012-03-05 17:20:37 with build 20120305031045

Still have not been able to reproduce the issue as of yet.

Possible dual core bug?
Crash Signature: [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.Abs… → [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.AbsoluteLayout@4054b560 at android.view.ViewGroup.updateViewLayout(ViewGroup.java)] [@ java.lang.IllegalArgumentException: Given view not a child of android.widget.Abs…
Assignee: nobody → cpeterson

Comment 10

6 years ago
It represents 8% of crashes over the last 3 days making it #2 top crasher.
snorp, is this crash related to Flash?
Assignee: cpeterson → snorp
Duplicate of this bug: 736318
It's not related to flash after all. I did hit this issue.  It's some sort of race condition I believe.


STR:
1. go to http://www.yahoo.co.jp
2. click on a link
3. before it turns over to the new page, hit back button
4. repeat 2 to 3... 

it's some timing issue with building the layout and changing the page somehow; ie back button, quitting, new tab, etc...
https://crash-stats.mozilla.com/report/index/8adf378d-5d2d-425d-bac0-a3b642120323
Created attachment 608551 [details] [diff] [review]
Don't reposition Android plugin views that aren't in view hierarchy
Attachment #608551 - Flags: review?(blassey.bugs)

Updated

6 years ago
Keywords: reproducible
Whiteboard: [native-crash], str-wanted, qa+ → [native-crash][qa+]
Attachment #608551 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/b05d102a6406

Updated

6 years ago
status-firefox13: --- → affected
Target Milestone: --- → Firefox 14
https://hg.mozilla.org/mozilla-central/rev/b05d102a6406
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 18

6 years ago
Based on crash stats (no crashes from 14..0a1/20120325), I mark it as verified.

It's still a top crasher in Aurora.
status-firefox14: --- → verified
Comment on attachment 608551 [details] [diff] [review]
Don't reposition Android plugin views that aren't in view hierarchy

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #608551 - Flags: approval-mozilla-aurora?
Comment on attachment 608551 [details] [diff] [review]
Don't reposition Android plugin views that aren't in view hierarchy

[Triage Comment]
Mobile only - approved for Aurora 13.
Attachment #608551 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/9303899517ac
status-firefox13: affected → fixed
I cannot reproduce this issue on the latest Nightly or Aurora by performing the str from comment #13.

Naoki, are you able to reproduce it anymore? If not, I guess that we can close it as verified fixed.
Still not able to reproduce this crash, and also it seems that there are no related crashes in the last week. Closing bug as verified fixed on:

Firefox 15.0a1 (2012-05-30)
Firefox 14.0a2 (2012-05-30)

Device: Galaxy Nexus
OS: Android 4.0.2
Status: RESOLVED → VERIFIED
status-firefox15: --- → verified
removing [qa+], bug verified from comment 23
Whiteboard: [native-crash][qa+] → [native-crash]
You need to log in before you can comment on or make changes to this bug.