Last Comment Bug 725230 - Enable and fix assertions in linker code
: Enable and fix assertions in linker code
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: mozglue (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla13
Assigned To: Mike Hommey [:glandium]
:
: Mike Hommey [:glandium]
Mentors:
Depends on: 717540
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-08 01:07 PST by Mike Hommey [:glandium]
Modified: 2012-02-15 08:45 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Enable and fix assertions in linker code (6.71 KB, patch)
2012-02-08 01:55 PST, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Enable and fix assertions in linker code (7.17 KB, patch)
2012-02-08 06:54 PST, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Enable and fix assertions in linker code (9.68 KB, patch)
2012-02-08 10:31 PST, Mike Hommey [:glandium]
taras.mozilla: review+
Details | Diff | Splinter Review

Description User image Mike Hommey [:glandium] 2012-02-08 01:07:22 PST
The linker has a bunch of commented out assertions in wait for mfbt to stop using JS_Assert. Some of them are logically backwards, so fix them, too.
Comment 1 User image Mike Hommey [:glandium] 2012-02-08 01:55:44 PST
Created attachment 595350 [details] [diff] [review]
Enable and fix assertions in linker code

The mozglue/linker/ElfLoader.cpp change is because I was getting an assertion because of refcounting. That made me realize that deleting these objects actually does dlclose(), which is what we wanted to avoid in the first place (see comment earlier in ~ElfLoader).
Comment 2 User image Mike Hommey [:glandium] 2012-02-08 01:56:32 PST
Comment on attachment 595350 [details] [diff] [review]
Enable and fix assertions in linker code

See comment 1.
Comment 3 User image Mike Hommey [:glandium] 2012-02-08 06:54:00 PST
Created attachment 595398 [details] [diff] [review]
Enable and fix assertions in linker code
Comment 4 User image Mike Hommey [:glandium] 2012-02-08 09:50:37 PST
Comment on attachment 595398 [details] [diff] [review]
Enable and fix assertions in linker code

There are some problems arisen by these assertions that need some fixing first.
Comment 5 User image Mike Hommey [:glandium] 2012-02-08 10:31:59 PST
Created attachment 595447 [details] [diff] [review]
Enable and fix assertions in linker code

I was getting assertions on refcounting for zips from APKOpen.cpp. MFBT doesn't really support non-refcounted instantiation.
Comment 7 User image Mike Hommey [:glandium] 2012-02-13 07:38:29 PST
Backed out with bug 717540.
https://hg.mozilla.org/integration/mozilla-inbound/rev/e652994cdd9e
Comment 9 User image Marco Bonardo [::mak] 2012-02-15 08:45:40 PST
https://hg.mozilla.org/mozilla-central/rev/91d77c934b26

Note You need to log in before you can comment on or make changes to this bug.