URI attributes in HTML DOM should be absolute

RESOLVED DUPLICATE of bug 47534

Status

()

defect
P4
normal
RESOLVED DUPLICATE of bug 47534
19 years ago
11 years ago

People

(Reporter: sicking, Unassigned)

Tracking

({dom1})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

URI attributes in the HTML DOM should be resolved to absolute URIs even if the 
markup attribute is relative. The URIs has to be resolved agains both xml:base 
and <html:base>, so i'll guess this is somewhat dependent on bug 72522.

List of attributes that should be resolved:
HTMLHeadElement.profile
HTMLHeadElement.href
HTMLBodyElement.background
HTMLBlockquoteElement.cite
HTMLQuoteElement.cite
HTMLModElement.cite
HTMLImageElement.lowSrc
HTMLImageElement.longDesc
HTMLObjectElement.codeBase
HTMLObjectElement.data (against HTMLObjectElement.codeBase)
HTMLAppletElement.codeBase
HTMLAppletElement.code (against HTMLAppletElement.codeBase)
HTMLScriptElement.src (might be done already)
HTMLFrameElement.longDesc
HTMLFrameElement.src (might be done already)
HTMLIFrameElement.longDesc
HTMLIFrameElement.src (might be done already)

And I think (w3c.org is down at the moment):
HTMLObjectElement.archive (against HTMLObjectElement.codeBase)
I agree (but I didn't look closely at your list yet).
Target Milestone: --- → mozilla1.0
Updating QA contact to Shivakiran Tummala.
QA Contact: desale → stummala
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
Bug 47534 has some properties not in this list that should also be absolute
Priority: -- → P4
Target Milestone: mozilla1.0.1 → ---
Mass-reassigning bugs.
Assignee: jst → dom_bugs
Fixed by bug 47534

*** This bug has been marked as a duplicate of 47534 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.