"Bookmark All Tabs" dialog window doesn't resize properly (gtk)

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: Patrick, Assigned: Seif Lotfy)

Tracking

10 Branch
Firefox 29
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox29 verified)

Details

(Whiteboard: [good first verify])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Created attachment 595361 [details]
Screenshot at 2012-02-08 11:51:41.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129141257

Steps to reproduce:

- Right click on any Tab in the tab bar
- choose "Bookmark All Tabs"
- resize (enlarge) the window vertically


Actual results:

The window resized but the elements within did not


Expected results:

The elements within (bookmarks folder tree) should have been resized to fill the available space inside the enlarged window.

Comment 1

6 years ago
Marco -> Is this a bookmark issue or something else?
Component: Untriaged → Bookmarks & History
QA Contact: untriaged → bookmarks
yes, it's not a gtk/widget issue it's just that nothing inside the dialog is vertically resizable.

Updated

5 years ago
Summary: "Boorkmark All Tabs" dialog window doesn't resize properly (gtk) → "Bookmark All Tabs" dialog window doesn't resize properly (gtk)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

4 years ago
Created attachment 8351438 [details] [diff] [review]
0001-Bug-725252-Bookmark-All-Tabs-dialog-window-doesn-t-r.patch

There were missing flex properties in the xul. I added those + a minheight.
(Assignee)

Updated

4 years ago
Attachment #8351438 - Flags: superreview?
Attachment #8351438 - Flags: review?(mak77)
Attachment #8351438 - Flags: review?(josh)

Comment 4

4 years ago
Comment on attachment 8351438 [details] [diff] [review]
0001-Bug-725252-Bookmark-All-Tabs-dialog-window-doesn-t-r.patch

No need to tag me here; I don't know this code at all. No superreview required either.
Attachment #8351438 - Flags: superreview?
Attachment #8351438 - Flags: review?(josh)
Comment on attachment 8351438 [details] [diff] [review]
0001-Bug-725252-Bookmark-All-Tabs-dialog-window-doesn-t-r.patch

Review of attachment 8351438 [details] [diff] [review]:
-----------------------------------------------------------------

I was a bit worried cause I was faintly remembering there was a reason we didn't make this and moreover the overlay is spread into many dialogs. But I tested it and it doesn't seem to cause any issue. I suspect some of the changes we made to the properties dialog last year may have solved some problem.
The patch is not solving all of the issues with this resizable dialog (if you don't expand the folder picker and resize the window, you still get a large grey area, while the picker should probably expand when over a certain threshold), but it's exactly solving this bug as it is filed, so I'd say we can take it and see, other issues may be handled apart in separate reports.

Before setting the checkin-needed keyword, please fix the commit message, so that it's in the usual form "Bug ###### - Description of the change. r=reviewer".

Thank you
Attachment #8351438 - Flags: review?(mak77) → review+
(Assignee)

Comment 6

4 years ago
Created attachment 8358785 [details] [diff] [review]
0001-Bug-725252-Bookmark-All-Tabs-dialog-window-doesn-t-r.patch

Voila :D
Attachment #8351438 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Attachment #8358785 - Flags: checkin?(mak77)
https://hg.mozilla.org/integration/fx-team/rev/a8906b3529a3
Assignee: nobody → seif
Whiteboard: [fixed-in-fx-team]
Comment on attachment 8358785 [details] [diff] [review]
0001-Bug-725252-Bookmark-All-Tabs-dialog-window-doesn-t-r.patch

In the future, please just set the checkin-needed bug keyword. Thanks for the patch!
Attachment #8358785 - Flags: checkin?(mak77) → checkin+
https://hg.mozilla.org/mozilla-central/rev/a8906b3529a3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29

Updated

4 years ago
Whiteboard: [good first verify]
[bugday-20140402]

Hi, 

I cannot reproduce the problem anymore in  Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140331125246
https://hg.mozilla.org/releases/mozilla-beta/rev/6ca67f136635
status-firefox29: --- → verified
Hi,

as target-milestone is set to 29, I'm changing the global status to Verified as per comment 10. Feel free to revert if this is not correct. 

Cheers,
Francesca
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.