[Skia] Crash Report [@ _ZN8SkBitmapaSERKS_ ] on HTC devices

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
P1
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Paul Feher, Unassigned)

Tracking

({crash, reproducible})

Trunk
ARM
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(firefox11 affected, firefox12 affected, firefox13 affected)

Details

(Whiteboard: [native-crash], crash signature)

(Reporter)

Description

6 years ago
Nightly: Fennec/13.0a1(2012-02-08)
Device: HTC Desire Z (Android 2.3)

Possible steps to reproduce:
1. Visit http://www.popuptest.com/popuptest1.html
2. Click the "Always show" button on the doorhanger notification.
3. Reload the page and check to see that pop-up(s) appears.

Expected result:
all should work fine

Actual result:
I got crash: 0b0f88df-0bc6-42a5-bea5-4fde52120208

NOTE: This was a one time bug. Is not reproducible.
https://crash-stats.mozilla.com/report/index/0b0f88df-0bc6-42a5-bea5-4fde52120208

Maybe it had to do with the timing of the reload and the dismissal of the doorhanger?  Not sure.
Keywords: crash
Whiteboard: [native-crash]

Comment 2

6 years ago
All crashes happen on HTC devices.
Severity: normal → critical
Crash Signature: [@ _ZN8SkBitmapaSERKS_]
status-firefox11: --- → affected
status-firefox12: --- → affected
status-firefox13: --- → affected
Keywords: reproducible
Summary: Crash Report [@ _ZN8SkBitmapaSERKS_ ] → Crash Report [@ _ZN8SkBitmapaSERKS_ ] on HTC devices
I was able to reproduce crashing, and it gave me a different crash stack:
https://crash-stats.mozilla.com/report/index/a94460b0-6a93-43ed-b069-4113e2120208


1. Visit http://www.popuptest.com/popuptest1.html
2. Click the "Always show" button on the doorhanger notification.
3. while pages are being loaded, click on the tab panel, go to the first page and then reload
4. repeat step 3 again.

Eventually you will crash.  This was on the HTC flyer (based on Scoobi's comment 2)
Crash Signature: [@ _ZN8SkBitmapaSERKS_] → [@ _ZN8SkBitmapaSERKS_] [@ libskia.so@0x505c0 ]
tracking-fennec: --- → ?

Comment 4

6 years ago
It's #1 unfixed top crasher in 12.0a2 (excluding startup crashes)
It has been hit by 8 different users for the last 3 days.
Keywords: topcrash

Updated

6 years ago
Summary: Crash Report [@ _ZN8SkBitmapaSERKS_ ] on HTC devices → [Skia] Crash Report [@ _ZN8SkBitmapaSERKS_ ] on HTC devices

Updated

6 years ago
Priority: -- → P1

Updated

6 years ago
tracking-fennec: ? → ---

Comment 5

6 years ago
Does it happen in FennecAndroid 13.0a2 and FennecAndroid 14.0a1?

Updated

6 years ago
Keywords: topcrash
Scoobi, Thanks for the reminder to check after Maple had landed.

Having some issues with the office wireless.  Can someone check this out please?  Otherwise it will have to wait til next week for me to test from home when I have internet.
Hrm, not sure what happened, but I can get through now.  Not crashing any more due to this crash, however there's something funny going on with the popup notification.  

Closing this as WFM.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.