Closed Bug 725296 Opened 8 years ago Closed 3 years ago

Browser is unresponsive while Silverlight content is loading

Categories

(Core :: Plug-ins, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: mihaelav, Unassigned)

References

Details

(Whiteboard: [11b2])

Firefox experiences no responsiveness while interactive Silverlight content is loading.

STR:
1. Go to http://www.silverlight.net/showcase and select an app from the gallery (e.g. TJCOMBO.NET)
2. Visit the website an interact with Silverlight content (right click, click, etc)

Actual result: 
While Silverlight content is loading/refreshing, the browser is unresponsive. (Issue is more obvious on http://www.tjcombo.net/ - right click on Silverlight content and then move focus to other browser components: tabs, awesome bar, etc)

Expected result:
Browser should not fail to respond when Silverlight conent is loading.

Notes: 
1. Issue is reproducble on Chrome, but NOT on IE7 and Opera 11.61
2. Issue is reproducible also on older Firefox versions (e.g. 9.0.1)
Builds:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0a1) Gecko/20120208 Firefox/13.0a1
Mozilla/5.0 (Windows NT 5.1; rv:13.0a1) Gecko/20120207 Firefox/13.0a1
Mozilla/5.0 (Windows NT 6.0; rv:11.0) Gecko/20100101 Firefox/11.0

Issue is also reproducible on Firefox 11 beta 2.
Whiteboard: [11b2]
Can you please investigate the regression range for this bug?
Bug is reproducible since Firefox 3.6
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16
Reproducible also on  
Mozilla/5.0 (Windows NT 6.1; rv:10.0.3) Gecko/20100101 Firefox/10.0.3 ESR
Mihaela, as previously requested please track down a regression range. You can use the mozregression tool.
I could not find a regression range using the mozregression tool since I got some errors (tried on several systems), but I was able to reproduce on 3.5.19, but not on 3.0b3pre (Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9b3pre) Gecko/2008010405 Minefield/3.0b3pre)
There does not appear to be a regression here, so asking for a regression range seems silly. This is most likely a bug in silverlight and not something we need to track.
Duplicate of this bug: 728561
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.