If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

(Vimeo) Video doesn't enter full screen correctly when using context menu

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
6 years ago
a year ago

People

(Reporter: mihaelav, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
OS: all Windows

Flash loses focus when entering full screen on Vimeo using context nenu.

STR:
1. Go to vimeo.com.
2. Play a video.
3. Right click on the video and select "Enter full screen".

Actual result:
New Adobe Flash Player instance opens inthe task bar (for full screen video) but the full screen is not focused:
- taskbar is displayed over the full screen video 
OR
- both taskbar and browser window are displayed over the full screen video
If the new Flash icon is selected from the taskbar or full screen video is clicked, full screen video gets the focus and shows correctly.

Expected result:
Full screen should load properly and have full focus.

Notes:
1. Entering full screen mode by using the video full screen button works correctly.
2. Issue is not reproducible on Opera 11.61.

Mozilla/5.0 (Windows NT 5.1; rv:13.0a1) Gecko/20120207 Firefox/13.0a1

Comment 1

6 years ago
Is this a recent regression from bug 90268?
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> Is this a recent regression from bug 90268?

This also affects Firefox 10.0.1 and 10.0.1 ESR so I don't think it's a regression from that bug Benjamin.
Keywords: regressionwindow-wanted
Further testing shows that this regressed sometime between Firefox 7 and Firefox 8.
Last good nightly: 2011-07-27
First bad nightly: 2011-07-28

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0a936ddb70e9&tochan
ge=a627b24e684e
Keywords: regressionwindow-wanted → regression

Comment 5

6 years ago
Almost certainly bug 665315
Blocks: 665315
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0

I have tried to reproduce this issue on Win 10 x64 and Win XP, using the latest Firefox release (46.0.1) and the latest Nightly build (49.0a1-20160601030219). But with the latest Adobe Flash player (21.0.0.242) installed, I was unable to.
Now when playing a video, the browser context-menu is displayed instead of the Flash one, and the "Fullscreen Mode" option is no longer available. Also, it seams that Vimeo no longer uses flash player for more than two years now.  

However, after I made some diggings, found out that this issue was on Adobe's side and the context menu "Full screen" option was droped since Flash player 11.3.300.271 (https://bugbase.adobe.com/index.cfm?event=bug&id=3310959).  

Considering these, I am closing this issue as Resolved-INVALID.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.