Closed Bug 725307 Opened 8 years ago Closed 8 years ago

pgo settings are inconsistent between release & nightly mozconfigs on mozilla-release and mozilla-esr10

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: bhearsum, Assigned: rail)

References

Details

(Whiteboard: [automation][releases])

We get a whole bunch of complains in the mozconfig comparison for them:
2012-02-08 05:31:05,487 : ERROR : not in release mozconfig's whitelist (releases/mozilla-release/win32/nightly) : mk_add_options MOZ_PGO=1
2012-02-08 05:31:23,229 : ERROR : not in release mozconfig's whitelist (releases/mozilla-release/linux64/nightly) : mk_add_options MOZ_PGO=1
2012-02-08 05:31:23,229 : ERROR : not in release mozconfig's whitelist (releases/mozilla-release/linux64/nightly) : mk_add_options PROFILE_GEN_SCRIPT='$(PYTHON) @MOZ_OBJDIR@/_profile/pgo/profileserver.py 10'
2012-02-08 05:31:37,827 : ERROR : not in release mozconfig's whitelist (releases/mozilla-release/linux/nightly) : mk_add_options MOZ_PGO=1
2012-02-08 05:31:37,827 : ERROR : not in release mozconfig's whitelist (releases/mozilla-release/linux/nightly) : mk_add_options PROFILE_GEN_SCRIPT='$(PYTHON) @MOZ_OBJDIR@/_profile

I'm pretty sure both of these branches are supposed to have PGO on for dep builds, which use the nightly mozconfig, as well as release builds. I think we need to fix up the nightly mozconfigs to be consistent with release.
Duplicate of this bug: 723308
Component: Release Engineering → Release Engineering: Automation
QA Contact: release → catlee
Assignee: nobody → rail
I tested updated release_sanity.py against esr10 and beta (which will be release this week) and it doesn't complain about mozconfigs anymore.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.