Last Comment Bug 725535 - "ASSERTION: Only transformed frames should have UpdateTransformLayer hint"
: "ASSERTION: Only transformed frames should have UpdateTransformLayer hint"
Status: RESOLVED FIXED
: assertion, regression, testcase
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Mats Palmgren (vacation)
:
Mentors:
Depends on:
Blocks: randomstyles 722923
  Show dependency treegraph
 
Reported: 2012-02-08 17:02 PST by Jesse Ruderman
Modified: 2012-02-14 02:35 PST (History)
5 users (show)
mats: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (155 bytes, text/html)
2012-02-08 17:02 PST, Jesse Ruderman
no flags Details
stack trace (4.96 KB, text/plain)
2012-02-08 17:05 PST, Jesse Ruderman
no flags Details
the frames involved (5.04 KB, text/plain)
2012-02-09 09:19 PST, Mats Palmgren (vacation)
no flags Details
fix+test (2.96 KB, patch)
2012-02-09 09:23 PST, Mats Palmgren (vacation)
roc: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2012-02-08 17:02:05 PST
Created attachment 595584 [details]
testcase

###!!! ASSERTION: Only transformed frames should have UpdateTransformLayer hint: '!(aChange & nsChangeHint_UpdateTransformLayer) || aFrame->IsTransformed()', file layout/base/nsCSSFrameConstructor.cpp, line 7678

This assertion was added in mozilla-central rev 6784eefe33a6 (bug 722923).
Comment 1 Jesse Ruderman 2012-02-08 17:05:02 PST
Created attachment 595585 [details]
stack trace
Comment 2 Mats Palmgren (vacation) 2012-02-09 09:19:11 PST
Created attachment 595776 [details]
the frames involved
Comment 3 Mats Palmgren (vacation) 2012-02-09 09:23:15 PST
Created attachment 595777 [details] [diff] [review]
fix+test

The assert needs to be first in ApplyRenderingChangeToTree() because it
sometimes "adjusts" aFrame to an ancestor:

  // If the frame's background is propagated to an ancestor, walk up to
  // that ancestor.
  nsStyleContext *bgSC;
  while (!nsCSSRendering::FindBackground(aPresContext, aFrame, &bgSC)) {
    aFrame = aFrame->GetParent();
    NS_ASSERTION(aFrame, "root frame must paint");
  }
Comment 5 Phil Ringnalda (:philor, back in August) 2012-02-12 14:17:51 PST
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/0c1fdf386ac1 since I wasn't sure which reftest failures and which crashtest assertion count failures went with which cset in the push.
Comment 7 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-02-14 02:35:06 PST
https://hg.mozilla.org/mozilla-central/rev/76cf2be70d90

Note You need to log in before you can comment on or make changes to this bug.