Closed Bug 725596 Opened 13 years ago Closed 3 years ago

[10.7] Crash right after opening File open dialog [@ _class_getName ]

Categories

(Core :: Widget: Cocoa, defect)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: whimboo, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: crash)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a2) Gecko/20120207 Firefox/12.0a2 ID:20120207042017

I tried to upload an image via the Wordpress media library, and opening the file open dialog Firefox crashed immediately.

Crash report: bp-05437c71-fcf6-464b-b7eb-12f782120209

0 	libobjc.A.dylib 	_class_getName 	
1 	FinderKit 	FinderKit@0xc1772 	
2 	FinderKit 	FinderKit@0xbfda9 	
3 	DesktopServicesPriv 	DesktopServicesPriv@0x5692b 	
4 	FinderKit 	FinderKit@0x5cf2a 	
5 	FinderKit 	FinderKit@0x5d13f 	
6 	FinderKit 	FinderKit@0x93863 	
7 	FinderKit 	FinderKit@0xeeca8 	
8 	FinderKit 	FinderKit@0xcd900 	
9 	FinderKit 	FinderKit@0xf7d59 	


Given the list of crashes it looks like to be a 10.7 crash only. It has a less number of reports which go back to 6.0. So seems like it's caused by a change in 10.7.

I have no reproducible steps for now.
Keywords: crash
Version: 6 Branch → unspecified
Marcia, I see from your crash log that you had this crash on OS X 10.7.2.

It'll be interesting to see what happens with the file picker crashes on 10.7.3, which just came out.
Steven: I have been running 10.7.3 all during the development and I didn't see any real issues with file picker, but perhaps I wasn't using it enough.

If I hit this crash I don't recall - but I will keep a lookout for it.
If I would have some STR I could upgrade my machine to 10.7.3 but so far it was a one time only crash. I will also continue to have a look at.

Marking this as Resolved > Works for me since there are no more crashes in the past 6 months with this signature.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.