Last Comment Bug 725599 - B2G telephony: speakerEnabled does not work
: B2G telephony: speakerEnabled does not work
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla13
Assigned To: José Antonio Olivera Ortega [:jaoo]
:
: Andrew Overholt [:overholt]
Mentors:
: 725598 (view as bug list)
Depends on:
Blocks: b2g-telephony
  Show dependency treegraph
 
Reported: 2012-02-09 02:04 PST by Maria Angeles Oteo (:oteo)
Modified: 2012-02-10 11:29 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (1.16 KB, patch)
2012-02-10 01:46 PST, José Antonio Olivera Ortega [:jaoo]
philipp: review+
Details | Diff | Splinter Review

Description Maria Angeles Oteo (:oteo) 2012-02-09 02:04:23 PST
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/534.51.22 (KHTML, like Gecko) Version/5.1.1 Safari/534.51.22

Steps to reproduce:

Trying to activate/deactivate the speaker in Samsung Galaxy SII 


Actual results:

Setting the attribute navigator.mozTelephony.speakerEnabled either to true or false we get the following errors in the log:

E/GeckoConsole( 6203): [JavaScript Error: "uncaught exception:
[Exception... "'[JavaScript Error: "gAudioManager.setForceUse is not a
function" {file:
"jar:file:///system/b2g/omni.ja!/components/RadioInterfaceLayer.js" line:
419}]' when calling method: [nsIRadioInterfaceLayer::speakerEnabled]"
nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"
location: "JS frame :: http://localhost:6666/Telephony/script/dialer.js ::
<TOP_LEVEL> :: line 579"  data: yes]"]
E/GeckoConsole( 6203): [JavaScript Error: "uncaught exception:
[Exception... "'[JavaScript Error: "gAudioManager.setForceUse is not a
function" {file:
"jar:file:///system/b2g/omni.ja!/components/RadioInterfaceLayer.js" line:
419}]' when calling method: [nsIRadioInterfaceLayer::speakerEnabled]"
nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"
location: "JS frame :: http://localhost:6666/Telephony/script/dialer.js ::
<TOP_LEVEL> :: line 579"  data: yes]"]
E/GeckoConsole( 6203): [JavaScript Error: "uncaught exception:
[Exception... "'[JavaScript Error: "gAudioManager.setForceUse is not a
function" {file:
"jar:file:///system/b2g/omni.ja!/components/RadioInterfaceLayer.js" line:
419}]' when calling method: [nsIRadioInterfaceLayer::speakerEnabled]"
nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"
location: "JS frame :: http://localhost:6666/Telephony/script/dialer.js ::
<TOP_LEVEL> :: line 579"  data: yes]"]
Comment 1 Matthias Versen [:Matti] 2012-02-09 04:09:14 PST
*** Bug 725598 has been marked as a duplicate of this bug. ***
Comment 2 José Antonio Olivera Ortega [:jaoo] 2012-02-10 01:46:16 PST
Created attachment 595992 [details] [diff] [review]
v1

This patch fix an small problem ("gAudioManager.setForceUse is not a function") when enabling speakers on a call.
Comment 3 Philipp von Weitershausen [:philikon] 2012-02-10 10:59:05 PST
Comment on attachment 595992 [details] [diff] [review]
v1

Review of attachment 595992 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch! r=me
Comment 4 Philipp von Weitershausen [:philikon] 2012-02-10 11:23:30 PST
(Please file telephony bugs in the Core :: DOM: Device Interfaces section next time, and mark them blocking the b2g-telephony meta bug. Both of those will ensure that the right kind of people are notified via email. Thanks! :))
Comment 5 Philipp von Weitershausen [:philikon] 2012-02-10 11:29:45 PST
https://hg.mozilla.org/mozilla-central/rev/40da5acfe838

Note You need to log in before you can comment on or make changes to this bug.