Firefox 10 crash in js::mjit::FrameState::pushActiveFrame with Firebug 1.9.1 DOM tab (64-bit Ubuntu 10.04 and above)

RESOLVED DUPLICATE of bug 694594

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 694594
6 years ago
3 years ago

People

(Reporter: David Martín Clavo, Unassigned)

Tracking

({crash, regression, reproducible})

10 Branch
x86_64
Linux
crash, regression, reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

6 years ago
In Ubuntu 10.04 64bit, I upgraded from FF9 to FF10 (using https://launchpad.net/~mozillateam/+archive/firefox-stable ).

Using Firebug 1.9.1, Firefox crashes as soon as I use Firebug's DOM tab or type a variable / function name in the Firebug console.
This did not happen with FF9.

See https://groups.google.com/forum/#!topic/firebug/v7WosDjvIyg for more details.

Updated

6 years ago
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Crash Signature: https://crash-stats.mozilla.com/report/index/bp-986b8aaa-f00c-4430-8ab8-951b22120207 → [@ arena_chunk_tree_dirty_remove]
Component: General → JavaScript Engine
Ever confirmed: true
Keywords: crash
Priority: P4 → --
Product: Firefox → Core
QA Contact: general → general
Summary: Firefox 10 crashes with Firebug 1.9.1 DOM tab (Ubuntu 10.04 64 bit) → Firefox 10 crash in js::mjit::FrameState::pushActiveFrame with Firebug 1.9.1 DOM tab (Ubuntu 10.04 64 bit)

Comment 1

6 years ago
I have the same problem. I've noticed that this also happens with the built in Web Console in FF10. not just in Firebug. Same symptom; start typing a function name or variable name (or almost anything) into the console and Firefox crashes. Also running Ubuntu 10.04 64-bit, and this did not happen in FF9 (but has been a problem in FF10 for at least the last couple months). It's also currently a problem in the FF11 beta.
Could you bisect this with nightly builds to find the day when it started?

Updated

6 years ago
Keywords: regression, regressionwindow-wanted

Comment 3

6 years ago
I'm also experiencing this.  

Additional steps to reproduce: paste any text into the firebug console, wait 3 seconds.

Firebug 1.9.1
FF 10.0 / Ubuntu canonical 1.0
Ubuntu 10.04 64-bit

Comment 4

6 years ago
(In reply to David Mandelin from comment #2)
> Could you bisect this with nightly builds to find the day when it started?

Mind explaining what this means and pointing to some instructions on how to do it?
Steps to reproduce:

0. New profile
1. Open web console (CTRL-SHIFT-K)
2. Type "print" into console

Result: Crash
I cannot reproduce this with the release version of Firefox 10.  Only with Firefox 10 through mozillateam.  This may not be a mozilla bug.

Comment 7

6 years ago
The original googlegroups thread implied this only affects 64-bit systems (people on 32-bit machines didn't encounter it).  Were you testing FF10 on a 64-bit box?  Specifically, I've consistently reproduced this on multiple Ubuntu 10.04 64-bit boxes.

Comment 8

6 years ago
Actually you're right... back on my ubuntu 64-bit box and got FF 10.0.1 direct rather than through mozillateam.... works fine now.  Could be FF10 or it could be the ubuntu packaging, but the latest release version seems to have solved it.
(Reporter)

Comment 9

6 years ago
Hello,
I have tested it with this release: http://releases.mozilla.org/pub/mozilla.org/firefox/releases/10.0/linux-x86_64/en-US/ and also with the 10.0.1 one.
Works correctly with both, no crashes.
So something is going on with the mozillateam version...
Cheers,
David

Comment 10

6 years ago
Just tested 10.0, 10.0.1 and 11.0b2 from the mozilla FTP. All work fine. The bug does seem to be limited to the mozillateam release.

Comment 11

6 years ago
Additionally, running 10.0.1 from lucid-updates/main works fine too. I haven't tried the newest point release from the mozillateam repo because I won't want to jinx my now working version.

Comment 12

6 years ago
(In reply to Joe from comment #11)
> Additionally, running 10.0.1 from lucid-updates/main works fine too. I
> haven't tried the newest point release from the mozillateam repo because I
> won't want to jinx my now working version.

Sorry, spoke too soon. The version out of the Ubuntu repo also crashes. The versions from Mozilla's FTP are all working correctly though. Seems we need to file this bug with Ubuntu (and perhaps mozillateam).

Comment 13

6 years ago
I seem to have this problem with both mozillateam and Ubuntu versions, both 10.0.0 and 10.0.1. Running Ubuntu 10.04 64-bit.

Comment 14

6 years ago
I'm observing this problem as well, crashing either by clicking DOM tab in Firebug 1.9.1 or by typing in the web console command line. 

I reported a bug to ubuntu: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/931637

Firefox 10.0.1, Ubuntu 10.04 64-bit running on Lenovo Thinkpad W510.

Comment 15

6 years ago
Also having this problem.

Firebug 1.9.1
FF 10.0
Ubuntu 10.04 64-bit

Comment 16

6 years ago
BTW, if you are having this issue, don't forget to give it a vote :)

Comment 17

6 years ago
An answer to comment 2 is still expected from someone who can reliably hit it.
For more, see http://harthur.github.com/mozregression/

Comment 18

6 years ago
(In reply to Scoobidiver from comment #17)
> An answer to comment 2 is still expected from someone who can reliably hit
> it.
> For more, see http://harthur.github.com/mozregression/

I don't think it's going to pop up here as it seems to be limited to the Ubuntu and mozillateam's repos. That said, I'll give this a spin and report back.

Comment 19

6 years ago
As I expected, no problems with any of the nightly builds for the last 2 months. Any idea where I can find old builds from the Ubuntu and Mozillateam repos? It looks like they remove the old stuff as the new rolls out, but I imagine they are cached somewhere, I just couldn't find anything. 

This has been a problem in the mozillateam repo since the 11 beta's but I don't exactly which version they started with. Also, can't speak to the 32 bit version, seems everyone having issues is having them with the 64 bit version (and on Ubuntu 10.04 specifically).
(Reporter)

Comment 20

6 years ago
Firefox 10.0.1 hit the mozilla-team repo today. Problem still happens.

Comment 21

6 years ago
As pointed out by Bjorn Christianson in comment 14, there's a bug report on Ubuntu's Launchpad now (thanks Bjorn). We're probably more likely to get help over there since this isn't a problem with the default Mozilla build.

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/931637

Comment 22

6 years ago
Yes, please, if you're having the issue, report it on Launchpad so we can get the heat up and get it fixed. 

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/931637

Comment 23

6 years ago
(In reply to Matt from comment #5)
> Steps to reproduce:
> 
> 0. New profile
> 1. Open web console (CTRL-SHIFT-K)
> 2. Type "print" into console
> 
> Result: Crash

Totally reproducible here FF 10 FB 1.9.1
Ubuntu 11.04 64 bit

Updated

6 years ago
Keywords: reproducible

Comment 24

6 years ago
Bug title should be renamed to ubuntu 10.4 11.4 as it's not specific to 10.4

Updated

6 years ago
Summary: Firefox 10 crash in js::mjit::FrameState::pushActiveFrame with Firebug 1.9.1 DOM tab (Ubuntu 10.04 64 bit) → Firefox 10 crash in js::mjit::FrameState::pushActiveFrame with Firebug 1.9.1 DOM tab (64-bit Ubuntu 10.04 and above)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 694594

Comment 26

6 years ago
(In reply to Chris Coulson from comment #25)
> 
> *** This bug has been marked as a duplicate of bug 694594 ***

How exactly is this a duplicate?

Comment 27

6 years ago
There is a memory corruption bug affecting builds of Firefox built with gcc 4.4.3 (ie, Ubuntu 10.04 and 10.10) which is responsible for these crashes with Firebug and the Web Console.
(In reply to Bjorn Christianson from comment #26)

To see the similarity, compare comment 5 to bug 694594 comment 3.  The steps to reproduce are the same.

Comment 29

6 years ago
Whatever the root cause for me the auto completion in Firebug seemed to trigger the crash. 

As a quick and nasty workaround I extracted and removed the XPI for Firebug (firebug@software.joehewitt.com.xpi) and simply cleared out the bodies for the functions createCandidates, createCompletions and popupCandidates in content/firebug/console/autoCompleter.js. 

So far this seems to prevent Firefox from crashing.

P.S. I'm running Firefox 11 on Ubuntu 10.10 (32 bit) with Firebug 1.91.
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.