Last Comment Bug 725700 - Keyboard arrow keys and scrollbar buttons should have consistent scrolling distances
: Keyboard arrow keys and scrollbar buttons should have consistent scrolling di...
Status: VERIFIED FIXED
[Snappy:P1][fixed-in-fx-team]
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
Mentors:
Depends on:
Blocks: 710372
  Show dependency treegraph
 
Reported: 2012-02-09 09:25 PST by Jared Wein [:jaws] (please needinfo? me)
Modified: 2012-05-28 06:51 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for bug (4.10 KB, patch)
2012-02-14 16:26 PST, Jared Wein [:jaws] (please needinfo? me)
smontagu: review+
Details | Diff | Review
Patch for bug v2 (5.81 KB, patch)
2012-02-15 16:09 PST, Jared Wein [:jaws] (please needinfo? me)
smontagu: review+
Details | Diff | Review

Description Jared Wein [:jaws] (please needinfo? me) 2012-02-09 09:25:32 PST
Bug 635645 made keyboard arrow keys scroll two lines at a time. Bug 710373 made the scrollbar buttons scroll three lines at a time.

These scrolling distances should be consistent, and we should make the arrow keys scroll three lines at a time instead of two.

To make sure that these distances stay consistent going forward, these distances should use a shared preferences (possibly updated through about:config).
Comment 1 Jared Wein [:jaws] (please needinfo? me) 2012-02-14 16:26:55 PST
Created attachment 597236 [details] [diff] [review]
Patch for bug
Comment 2 Mozilla RelEng Bot 2012-02-15 12:43:27 PST
Autoland Patchset:
	Patches: 597236
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=6c47f76858c8
Try run started, revision 6c47f76858c8. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=6c47f76858c8
Comment 3 Jared Wein [:jaws] (please needinfo? me) 2012-02-15 16:09:54 PST
Created attachment 597601 [details] [diff] [review]
Patch for bug v2

The push to try showed that docshell/test/navigation/test_bug430723.html was broken since the test reached the bottom of the window before the scroll iterations were finished and the scroll event wouldn't fire anymore on DOWN key.

I've updated the test to scroll down less since the distance of scrolling has been increased.
Comment 4 Mozilla RelEng Bot 2012-02-15 19:16:23 PST
Try run for 6c47f76858c8 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=6c47f76858c8
Results (out of 212 total builds):
    success: 168
    warnings: 30
    failure: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-6c47f76858c8
Comment 5 Mozilla RelEng Bot 2012-02-15 19:25:09 PST
Autoland Patchset:
	Patches: 597601
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=c6f9bd404ae0
Try run started, revision c6f9bd404ae0. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=c6f9bd404ae0
Comment 6 Mozilla RelEng Bot 2012-02-16 01:16:47 PST
Try run for c6f9bd404ae0 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=c6f9bd404ae0
Results (out of 209 total builds):
    success: 145
    warnings: 13
    failure: 51
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-c6f9bd404ae0
Comment 7 Jared Wein [:jaws] (please needinfo? me) 2012-02-18 21:01:05 PST
review ping? only change from previous r+'d version is the test update.
Comment 8 Jared Wein [:jaws] (please needinfo? me) 2012-02-20 08:26:12 PST
https://hg.mozilla.org/integration/fx-team/rev/74cb4c127dc1
Comment 9 Rob Campbell [:rc] (:robcee) 2012-02-22 09:34:28 PST
https://hg.mozilla.org/mozilla-central/rev/74cb4c127dc1
Comment 10 Mihaela Velimiroviciu (:mihaelav) 2012-05-28 06:51:57 PDT
Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20100101 Firefox/13.0

Verified that both keyboard arrows and scrollbar buttons scroll about 3 lines at once.

Note You need to log in before you can comment on or make changes to this bug.