Closed Bug 725701 Opened 8 years ago Closed 8 years ago

Memory usage spike detected in Mozmill Endurance tests for Win 5.1.2600 x86

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 724553

People

(Reporter: mihaelav, Unassigned)

Details

There is a memory spike of about 30MB between Feb 6 and Feb 8 on the Win 5.1.2600 x86 nighlies.

Chart:
http://mozmill-release.blargon7.com/#/endurance/charts?branch=13.0&platform=All&from=2012-01-31&to=2012-03-13

Report from 2012-02-06:
http://mozmill-release.blargon7.com/#/endurance/report/a3c1112b91483a199fcd4a91cf04dee1

Report from 2012-02-07:
http://mozmill-release.blargon7.com/#/endurance/report/6c25050e24006b3ca556dcd53704cd8a

Report from 2012-02-08:
http://mozmill-release.blargon7.com/#/endurance/report/6c25050e24006b3ca556dcd5370c3fbf

Pushlog between Feb 6 and Feb 8:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2%2F6%2F2012&enddate=2%2F8%2F2012

Note: Win 6.0.6002 x86 also has higher memory usage in this period, but the difference is not so big (less than 10MB)
I'm not sure a spike of 30MB is enough to worry about on WinXP, especially since looking at the historical data it tends to fluctuate day to day. 

Looking at the data since the merge I can see the normal range is between 115MB and 140MB. I This does beg the question, what is a realistic threshold for error? 

Using the Explicit Memory numbers:
 * Average Max Memory: 131 MB
 * Max Max Memory: 143 MB
 * Min Max Memory: 115 MB
 * Std Deviation: 28 MB (21% of Average)

Given that, I think an acceptable norm is a 20% deviation. In the case of Firefox 13 on Windows XP that translates to ~130MB - ~194MB.

Dave, what do you think?
Yeah, this looks like quite a spike. It coincides with new tests landing but on inspection these new tests are not causing the spike. It looks to me like the private browsing test is causing this spike again.
Should we dupe to bug 724677?
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 724677
Sorry, wrong bug.
Duplicate of bug: 724553
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.