Last Comment Bug 725765 - Sprinter cleanup
: Sprinter cleanup
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- minor (vote)
: mozilla13
Assigned To: Adam
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-09 11:49 PST by Adam
Modified: 2012-02-16 03:06 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
sprinter-cleanup.diff (20.58 KB, patch)
2012-02-09 11:50 PST, Adam
jwalden+bmo: review+
Details | Diff | Splinter Review

Description Adam 2012-02-09 11:49:42 PST
Following bug #688891, this replaces the old API calls with the newer ones.
Comment 1 Adam 2012-02-09 11:50:28 PST
Created attachment 595835 [details] [diff] [review]
sprinter-cleanup.diff
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2012-02-15 16:08:22 PST
Comment on attachment 595835 [details] [diff] [review]
sprinter-cleanup.diff

Review of attachment 595835 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, save for the one nit.  I'll fix it and push for you.  Thanks!

::: js/src/jsopcode.cpp
@@ +1611,3 @@
>                               ? "0 / 0"
>                               : (d < 0)
>                               ? "1 / -0"

Please re-indent the rest of this condition, since you're touching this.
Comment 3 :Ms2ger 2012-02-16 02:19:12 PST
Bonus points if you add

template<size_t N>
ptrdiff_t put(const char (&s)[N])
{
  return put(s, N - 1);
}

and remove the explicit put(literal string, length of the literal string) calls. (Followup is fine, of course.)
Comment 4 :Ms2ger 2012-02-16 02:19:53 PST
And thanks for doing this!
Comment 5 Marco Bonardo [::mak] 2012-02-16 03:06:42 PST
https://hg.mozilla.org/mozilla-central/rev/ad596e4e1c79

Note You need to log in before you can comment on or make changes to this bug.