Robotium: Add tests for basic navigation

RESOLVED DUPLICATE of bug 747835

Status

()

P2
normal
RESOLVED DUPLICATE of bug 747835
7 years ago
2 years ago

People

(Reporter: mfinkle, Assigned: mfinkle)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 595864 [details] [diff] [review]
WIP

We should test to make sure the reload, forward and back operations work and the menu is updated.

The WIP patch seems to be a good start, but the getText("Forward").isEnabled() fails to return FASLE when I know (and can see) it is disabled. I even added a stupid mSolo.sleep(1000) to wait after the menu is shown, allowing the code to update the menus as needed.
Created attachment 595875 [details] [diff] [review]
WIP 2

With test file
Assignee: nobody → mark.finkle
Attachment #595864 - Attachment is obsolete: true
Comment on attachment 595875 [details] [diff] [review]
WIP 2

I'm guessing the waitForText is returning a TextView which is always going to be enabled. You're probably going to need to walk up the chain of UI elements until you get to the menu item object, aand check isEnabled() on that.
Priority: -- → P2
Please tell me we have basic automated navigational tests in some suite somewhere.
Yup
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 747835
You need to log in before you can comment on or make changes to this bug.