Provide releng with a panda board that can run unit tests

RESOLVED DUPLICATE of bug 769428

Status

RESOLVED DUPLICATE of bug 769428
7 years ago
5 years ago

People

(Reporter: armenzg, Assigned: cmtalbert)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ETA undetermined)

(Reporter)

Description

7 years ago
ctalbert says we can have a panda board with everything we need ready by next week.

I will be taking care of hooking it up to our staging systems once we're ready.
(Reporter)

Updated

7 years ago
Blocks: 725845
I have been working on building this from the AOSP project using these instructions:

http://source.android.com/source/building.html
http://source.android.com/source/building-devices.html
device/ti/panda/README (as checked out in the source) and a more realistic version on this blog: http://fosiao.com/node/19

I have been building the "eng" configuration, which apparently has some additional tools and (very importantly) is rooted by default.

The biggest gotcha I have found so far is that my panda board does not actually seem to reboot when you press the user button and toggle the power button. Not knowing this made me waste an entire day trying to figure out why things weren't working. Aside from that, things seem to work as expected, more or less.

So I gather the next step is to make sure this image that we install has SUTAgent and all the other stuff we want to run automation?
(Reporter)

Comment 2

7 years ago
From https://wiki.mozilla.org/Mobile/Testing/02_15_12#Panda_Boards

ctalbert/jmaher/wlach - have had minimal luck getting pandaboards to boot and run tests (mochitest and reftest samples so far). ctalbert and jmaher can't even get an image to boot.
* require proper power supply
* requiring building from tip of ICS
* require panda video driver
* possibly require specific type(s) of sdcard
Whiteboard: ETA undetermined
(Reporter)

Comment 3

7 years ago
I will be asking on the next Wednesday meeting for an updated timeline.
(Reporter)

Comment 4

7 years ago
ctalbert/jmaher/wlach: any updates since the 21st?

I would like to refresh our roadmap.
(Reporter)

Comment 5

7 years ago
armenzg: are you/blassey still working on getting a working board? how far is that?
ctalbert: ummm...where are we with the board.
ctalbert: yes, it works
ctalbert: we believe we have a system that we can use to image new boards
ctalbert: but we haven't tested it remotely with a pandaboard
ctalbert: but we can do that using wlach and/or jmaher's boards
ctalbert: so shall I put this guy in haxxor?
armenzg: oh yes please!
(Reporter)

Comment 6

7 years ago
ctalbert, what are the latest?
adding ted as he has been working on the panda board lately.
(Reporter)

Comment 8

6 years ago
ted fixed the MAC address issue.
We will be testing the builds in bug 769428 (once I know that I did not paste anything that should be confidential I will open up the bug).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769428
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.