Closed Bug 725846 Opened 9 years ago Closed 9 years ago

Buy 8 Panda ES boards to tinker with

Categories

(Release Engineering :: General, defect)

x86
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: armenzg, Assigned: armenzg)

References

Details

(Whiteboard: delivered - 2 shipped to armenzg and blassey)

We are going to be buying Panda ES boards with all needed accessories.
- 2 of them for IT
- 2 of them for the A-team
- 1 of them for me

I will wait to place the order until tomorrow.

ctalbert asked me to ship them to him on MV.

Who can I ship this to from IT?

I will wait to see if Kev can gets us a discount for the bulk purchase.
jmaher has requested that I hold off for a couple of days before he can figure something out with blassey.
blassey/ctalbert gave their blessings this morning on IRC.

Here is what I have in mind:
* 5 panda ES boards
* 3 power cables
* 1 USB cable
* 5 SD cards

* dividehex: 2 boards, 2 SD cards, 2 power cables, 0 USB cable
** I assume IT has USB cables at hand
* dtalbert: 2 boards, 0 SD cards, 0 power cable, 0 USB cable
** he has 5 power cables already and I assume SD cards
* armenzg: 1 board, 1 SD card, 1 power cable, 1 USB cable

I am on the phone with digikey. So far emails and quotes have been going unattended.
we need to get high end sdcards.  My pny card seems to be problematic and I heard that sandisk 4gb sdhc cards work well.
(thanks jmaher)

I ordered 5 boards to be shipped to the SF office to John O'Duinn.

There is a back-order (not confirmed date by manufacturer) of Feb. 29th 1055-1000-ND

Ordering the accessories was being a little complicated and I will try again.

On the other side if we ordered 500 right now (without confirmed dates) the schedule would be:
Feb. 29th  - 177
March 7th  - 250
March 21st - 73
Summary: Buy Panda ES boards to tinker with → Buy 5 Panda ES boards to tinker with
Whiteboard: backordered - next expected delivery on Feb. 29th
From https://wiki.mozilla.org/Mobile/Testing/02_15_12#Action_Items:
* armenzg to get an extra Panda ES board for blassey
Making it 8 (in case we need more than 1 extra). Changed shipping to be MV.

Once the A-team/blassey are closer to have a working board that releng can use we can order more.
Summary: Buy 5 Panda ES boards to tinker with → Buy 8 Panda ES boards to tinker with
For accessories I am looking at:
[1] https://specialcomp.com/pandaboard/order.htm

IT: FYI they have special casing for the boards.

jmaher: this card? http://www.futureshop.ca/en-CA/product/sandisk-4gb-sdhc-class-2-memory-card/10081602.aspx

jmaher: which of the USB cables is the one you use? (from [1])
I am using the same usb cable that I use for my tegra, so I don't know which specifically we need.

I am using a UHS 1 card:
http://www.futureshop.ca/en-CA/product/sandisk-sandisk-extreme-pro-8gb-sdhc-uhs-speed-class-1-memory-card-sdsdxp1-008g-x46/10168052.aspx?path=1ae4a11a40ec24dbf0159f4231bbdc41en02

Much more expensive but a LOT faster.
jmaher: does the speed of the card actually make a difference in the performance of the board (does it take advantage of the faster card)?  At one point we were going to conduct a test to see if it mattered if we bought faster cards, but I'm not sure if that ever happened.
I was unable to get the OS  on my class 4 card and bought a class 10 UHS-1 card and it worked as expected.  Buying a cheaper slower card is not a choice IMO.
(In reply to Amy Rich [:arich] [:arr] from comment #10)
> jmaher: does the speed of the card actually make a difference in the
> performance of the board (does it take advantage of the faster card)?  At
> one point we were going to conduct a test to see if it mattered if we bought
> faster cards, but I'm not sure if that ever happened.

And yes, I had a class 4 card and while the device was usable, it was slow. The uhs-1 (class 10) card is far better and the OS is far more performant.

Remember that the way these use sdcards are different from the tegras. In tegras the sdcard was simply extra storage. In pandas, the sdcard contains *the entire OS* so we want that as fast as we can get, and we want it standardized among the cards so that we don't get noise when we do performance tests on them.
Is there a test that can be run on a card before we put it into any panda board to ensure they meet expectations?
(In reply to Armen Zambrano G. [:armenzg] - Release Engineer from comment #13)
> Is there a test that can be run on a card before we put it into any panda
> board to ensure they meet expectations?

No, not really. We could devise something, but there is no "one" standard.
Here's the power adapter (using digikey codes/prices) [1]:
* 993-1019-ND - Desktop Power Supply - $23.57
I have ordered 5 of them since the A-team already has few extra power supplies.

The 8 boards and the 5 power adapters have been shipped early and will be there at the office on Monday.

I want to order the Sandisk Extreme PRO 8GB SDHC UHS Speed Class 1 Memory Card (which is equivalent/faster than normal SDHC class 10 [3] - 30MB/s vs 45MB/s)
Where can I order it in the U.S.? (I can order mine in here in Canada)

FTR here are the other parts that can be easily found/purchased
* Normal computer power cable
* HDMI-A Male to DVI-D Cable
* USB Mini-B Male to USB A Male

[1] "Associated products" tab:
http://www.digikey.com/product-highlights/us/en/texas-instruments-pandaboard/686#tabs-2
[2] http://www.futureshop.ca/en-CA/product/sandisk-sandisk-extreme-pro-8gb-sdhc-uhs-speed-class-1-memory-card-sdsdxp1-008g-x46/10168052.aspx?path=1ae4a11a40ec24dbf0159f4231bbdc41en02
[3] http://www.futureshop.ca/en-CA/product/sandisk-sandisk-extreme-8gb-sdhc-class-10-memory-card-sdsdx-008g-x46-sdsdx-008g-x46/10174244.aspx?path=79742e4e4c35fac86562b92b9ea5f166en02
Whiteboard: backordered - next expected delivery on Feb. 29th → expected to be delivered week of Feb. 27th
I won't be ordering any cards since the A-team have everything they need and anyone can order them through newegg.com:
http://www.newegg.com/Product/Product.aspx?Item=N82E16820171506

If anyone thinks that needs any of the other accessories please speak up and let me know if you have any info missing to order them.
(In reply to Armen Zambrano G. [:armenzg] - Release Engineer from comment #16)
> I won't be ordering any cards since the A-team have everything they need and
> anyone can order them through newegg.com:
> http://www.newegg.com/Product/Product.aspx?Item=N82E16820171506
> 
After talking with ctalbert I will get 5 SD cards.
I have asked joduinn to order them for me since I can't use a Canadian card and paypal did not work.
I mentioned it on IRC & emails but forgot to update the bug.

* We have received the 8 boards on MV.
* dividehex has given to Eric Little 2 boards to be shipped to me and blassey
* joduinn is going to order the SD cards today/tomorrow
* ctalbert is at MV and will be going to dividehex to grab the 4 boards allocated for the a-team
Whiteboard: expected to be delivered week of Feb. 27th → delivered - 2 shipped to armenzg and blassey
* ctalbert got his 4 boards
* bug 731694 will be used for the SD cards

Nothing left in this bug.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.