Closed Bug 725886 Opened 8 years ago Closed 7 years ago

Separate ThebesLayer painting from Compositing

Categories

(Core :: Web Painting, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 715433

People

(Reporter: mattwoodrow, Unassigned)

References

Details

Attachments

(1 file)

For display list based invalidation, we need to know the widget area to invalidate (generated from display list construction, layer construction, and ThebesLayer painting) before we trigger a widget paint event.

We need to split layer transactions into a Validate() phase that draws all thebes layer contents, and then a separate Composite() phase.

This is similar to what Shadow layers are doing ready.

D3D10 layers already supports Validate() properly, the other backends could probably use better implementations that what I have here.
Attachment #595911 - Attachment is patch: true
This is covered by the Great Layers Refactoring.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 715433
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.