Closed Bug 725975 Opened 9 years ago Closed 4 years ago

Adobe flash plugin crashes when swithching full screen mode on/off (CMD+SHIFT+F) with focus on flash content (video) (Single Core Processor)

Categories

(Core :: Plug-ins, defect)

6 Branch
x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mihaelav, Unassigned)

Details

(Keywords: crash, regression, Whiteboard: [11b2])

Crash Data

Environment:
Processor: 1.5GHz Intel Core Solo
Memory: 2GB 667 Mhz DDR2 SDRAM
Graphics: Intel GMA 950

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0a1) Gecko/20120207 Firefox/13.0a1

STR:
1. Go to a page thet contains flash content (e.g youtube/vimeo video)
2. Move focus to flash content
3. Use keyboard shortcuts to enter full screen
4. Use keyboard shortcuts to exit full screen

Expected result:
Browser should enter and exit full screen mode properly. No crash should occur.

Actual result:
Browser enters and exits full screen, but flash plugin crashes

Note: 
Crash is not reproducible on the following HW config:
Processor: 2GHz Intel Core 2 Duo
Memory: 4GB 667 Mhz DDR2 SDRAM
Graphics: Intel GMA 950
Which Flash version did you have?
Can you provide the two crash IDs (bp-...) from about:crashes, one for the browser side hang, one for the plugin side hang?
Severity: major → critical
Keywords: crash
In addition, is this only reproducible on Mac? is it a regression?
(In reply to Scoobidiver from comment #1)
> Which Flash version did you have?
> Can you provide the two crash IDs (bp-...) from about:crashes, one for the
> browser side hang, one for the plugin side hang?

Adobe Flash 11.1.102.55
There is no browse hang, only flash plugin crash. 
about:crashes - one of the report IDs: 9C2D760D-61C0-44AD-A53C-5EBB0775A756 (report was held back from submission; I don't have any report which was actually submitted)

(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #2)
> In addition, is this only reproducible on Mac? is it a regression?
Yes, I could reproduce this only on one Mac machine (HW described in comment #0).
It is reproducible since Firefox 6:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0
Mihaela, can you get a more specific regression range using the mozregression tool?
(In reply to Mihaela Velimiroviciu [QA] from comment #3)
> about:crashes - one of the report IDs: 9C2D760D-61C0-44AD-A53C-5EBB0775A756
> (report was held back from submission; I don't have any report which was
> actually submitted)
Can you click the link to make it submit (there's no throttling in Nightly) and post the new crash ID (bp-...)?
Version: 13 Branch → 6 Branch
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #4)
> Mihaela, can you get a more specific regression range using the
> mozregression tool?

Last good nightly: 2011-04-13
First bad nightly: 2011-04-14

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6bcaec19d09e&tochange=aa200a803e07

(In reply to Scoobidiver from comment #5)
> (In reply to Mihaela Velimiroviciu [QA] from comment #3)
> > about:crashes - one of the report IDs: 9C2D760D-61C0-44AD-A53C-5EBB0775A756
> > (report was held back from submission; I don't have any report which was
> > actually submitted)
> Can you click the link to make it submit (there's no throttling in Nightly)
> and post the new crash ID (bp-...)?

https://crash-stats.mozilla.com/report/index/bp-385c9d23-4a99-4111-a1ed-2e03f2120213
Version: 6 Branch → 13 Branch
It's a regression from Firefox 6.
Crash Signature: [@ libmozalloc.dylib@0xd56]
Version: 13 Branch → 6 Branch
How reproducible/prevalent is this crash?
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:16.0) Gecko/16.0 Firefox/16.0
http://hg.mozilla.org/mozilla-central/rev/1d370ca5bb8d

I cannot reproduce anymore because Firefox does not enter full screen when using keyboard shortcuts and focus is on flash content.
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year).
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.