Closed Bug 725982 Opened 9 years ago Closed 8 years ago

Flash player stops rendering on right click

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: vishvesh.com, Unassigned)

Details

Attachments

(1 file)

2.74 KB, text/plain
Details
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

1. Open any youtube page
2. Right Click on the player

 


Actual results:

Context menu is displayed and the player stops playing the video once all buffered contents are played.

I can generate this on Firefox 8, 9 amd 10


Expected results:

Context menu is displayed and the player should continue to play the video
WFM on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0.1) Gecko/20100101 Firefox/10.0.1 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0beta2

but I can reproduce this issue on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a2) Gecko/20120215 Firefox/12.0a2 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0a1) Gecko/20120214 Firefox/13.0a1

When the flash context menu is present, the video freezes but the sound plays on. When the context menu is gone the video plays on.
Is this only happening on Mac?
Status: UNCONFIRMED → NEW
Component: Untriaged → Flash (Adobe)
Ever confirmed: true
Product: Firefox → Plugins
QA Contact: untriaged → adobe-flash
Version: 10 Branch → unspecified
Don't see this on Windows XP and Windows 7.
This issue is back on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0 beta 3 build 2

I have tried on two different machines running MacOS X 10.6.8 and on my machine the issue is reproducing and on the other it's not.

Both have Shockwave Flash 11.1.102.62 installed.
The difference seems to be at first site the Shockwave for Director plugin.
This isn't reproducing on the Mac with Shockwave for Director 11.6.4r634.
My machine has 11.6.3r633 and for some unknown reasons I get update to the latest Shockwave so I can't confirm that this is the bug cause.
Are you saying that you can no longer reproduce this after updating Shockwave Director to the latest version?
I can reproduce the bug on my test machine with Shockwave 11.6.3r633 installed.
On the other machine, with 11.6.4r634 installed, the issue isn't reproducing. 
I wanted to update the shockwave on my machine to see if the problem is solved and to check that the only difference was this update and not the tech specs of the Macs.
I can generate this bug on Sling Player plug-in too. On right click "canDrawInCGLContext:pixelFormat:forLayerTime:displayTime:" method is not called. This stops the rendering.

Not sure how it would impact Flash Player. From what I have observed, flash player continues to play the buffered video and stops playing once it has played all the buffered video.
Vlad, did you get a chance to retest this with an updated Shockwave on the affected machine (as per comment 6)?
I've managed to install Shockwave for Director 11.6.4r634 on the affected machine and the issue is not reproducing anymore.
On right-click the video keeps on playing.
Resolving WORKSFORME based on comment 9. Please reopen if this is reproducible with the latest Shockwave plugin.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
This issue is back on 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0 beta 6
Version of flash installed is: 11.1.102.64
Version of Shockwave flash is: 11.6.4r634
considering this, I'm reopening this bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I've tested this on Google chrome with the same plugins from comment11 and it's happening exactly the same - this is again a flash bug
If this is a bug in the Shockwave Director plugin then why is this reopen?
the shockwave director and flash player are 2 diffeent plugins.  strictly going by the OP comment, he would be using the flash player for youtube.com.

i'm not able to repro on OS X 10.6.8 Firefox 10.0.2 release with flash 11,1,102,64.

i am able to reproduce in the Nightly on the same machine, so this is a regression i believe...
Attached file data
(In reply to Gabriel from comment #15)
> Created attachment 718231 [details]
> data

I already have this same bug with windows 7 64bit with clean windows install and firefox 20.0b1 clean too.
This bug has already a long time and is never get fix.
Every time the user report this bug suport say this is not a bug is an incompatibility with other addons. So now I already test with clean install and get this bug.
So need fix, alot people change your browser for that.
This was implemented by Flash on purpose, and will not be fixed.
Status: REOPENED → RESOLVED
Closed: 9 years ago8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.