Allow entering a message for recent contributors, even if you approve your own revision.

VERIFIED FIXED in 2012-03-06

Status

support.mozilla.org
Knowledge Base Software
P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: atopal, Assigned: rrosario)

Tracking

unspecified
2012-03-06

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributor c=wiki s=2012.4 p=1)

(Reporter)

Description

6 years ago
When you create a revision based on another revision and approve it, everyone before that in the history list should get a message. Currently it looks like, if you approve your own revision no one gets a message, even though it might have been based on another revision.
(Reporter)

Updated

6 years ago
Priority: -- → P2
(Assignee)

Comment 1

6 years ago
Should we still send to the approver approving his own?
Whiteboard: u=contributor c=wiki s=2012.4 p= → u=contributor c=wiki s=2012.4 p=1
Grabbing this to work on Monday or Tuesday.
Assignee: nobody → willkg
(Reporter)

Comment 3

6 years ago
Ricky, no the approver should not get the message he just sent out.
I can't reproduce this. Here are the steps I'm using:

1. log in with willkg
2. (as willkg) find an approved kb article and edit it adding another line
3. log in as verdi
4. (as verdi) edit the article based on the revision from step 2.
5. log in as scoobidiver
6. (as scoobidiver) edit the article based on the revision from step 4.
7. (as willkg) defer the revisions created in steps 2, 4, and 6.
8. (as willkg) edit the article based on the revision from step 6--this revision has all the revisions in it so far
9. approve the revision created in step 8.

According to the log, willkg approved his own revision and thus doesn't get an email. However, verdi and scoobidiver both get emails saying "A revision you contributed to has been approved".

I checked the code and it looks ok.

Do I misunderstand the problem here? Are the steps I'm using to reproduce incorrect?
(Assignee)

Comment 5

6 years ago
(In reply to Will Kahn-Greene [:willkg] from comment #4)
> I can't reproduce this. Here are the steps I'm using:

Those steps look right to me. I tried on stage and it WFM as well.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

6 years ago
To clarify, by "Send message" you mean email, correct? You don't mean that each contributor should be able to receive a custom message from the reviewer?

Comment 7

6 years ago
The issue here is not about the notification, it's about the message you send to someone when you approve or defer a revision. This is feedback you send the editor(s). If you are approving or deferring your own revision you don't get this opportunity even if your revision is based on the work of others. You should be able to send them all feedback.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 8

6 years ago
Oh, so it is just a UI issue? We just need to show the message textbox in all cases.

Comment 9

6 years ago
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #8)
> Oh, so it is just a UI issue? We just need to show the message textbox in
> all cases.

Well not in the case of approving your own revision and it's the only one.
(Assignee)

Updated

6 years ago
Assignee: willkg → rrosario
(Assignee)

Updated

6 years ago
Summary: Send message to contributors, even if you approve your own revision. → Allow entering a message for recent contributors, even if you approve your own revision.
(Assignee)

Comment 10

6 years ago
https://github.com/mozilla/kitsune/commit/2e2f85ae5cf92c1428134db59cec8056aad4d032
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2012-03-06
1) I reviewed my own revision and now get a text box- was this intended?
2) I deferred a revision that was for a change made by me, plus user1 & 2. The comment box sent a revision to user1 & 2 but not me. [as intended]
(Assignee)

Comment 12

6 years ago
(In reply to Rebecca Billings from comment #11)
> 1) I reviewed my own revision and now get a text box- was this intended?

Only if there are other revisions between the revision you are reviewing and the last one that was approved (current). I just tried on stage to approve and defer my own revision (with no other revisions/contributors) and it doesn't show the textbox.
Verified that comment box displays for multiple reviewers, but not when approving/deferring your own revisions.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.