Last Comment Bug 726115 - GC: indirect JSTraceCallback
: GC: indirect JSTraceCallback
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Terrence Cole [:terrence]
:
Mentors:
Depends on: 721463
Blocks: 720522
  Show dependency treegraph
 
Reported: 2012-02-10 11:55 PST by Terrence Cole [:terrence]
Modified: 2012-02-16 03:07 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (13.65 KB, patch)
2012-02-10 11:55 PST, Terrence Cole [:terrence]
wmccloskey: review+
Details | Diff | Splinter Review

Description Terrence Cole [:terrence] 2012-02-10 11:55:38 PST
Created attachment 596130 [details] [diff] [review]
v1

It occurred to me that my indirect marking patch was going to be insanely difficult to review because of the spread-out-but-interdependent and thoroughly overlapping nature of the changes.  Thus I'm splitting it up into several non-overlapping pieces that we should be able to test and push relatively independently.  I've decided to make this the first piece since it is an interface change that touches the browser.
Comment 1 Bill McCloskey (:billm) 2012-02-15 16:03:12 PST
Comment on attachment 596130 [details] [diff] [review]
v1

Review of attachment 596130 [details] [diff] [review]:
-----------------------------------------------------------------

Great!
Comment 2 Terrence Cole [:terrence] 2012-02-15 17:33:55 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/0731076ace50
Comment 3 Marco Bonardo [::mak] 2012-02-16 03:07:43 PST
https://hg.mozilla.org/mozilla-central/rev/0731076ace50

Note You need to log in before you can comment on or make changes to this bug.