Last Comment Bug 726182 - Add JS_GetFunctionPrototype
: Add JS_GetFunctionPrototype
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla13
Assigned To: Boris Zbarsky [:bz] (Out June 25-July 6)
:
Mentors:
Depends on:
Blocks: 725888
  Show dependency treegraph
 
Reported: 2012-02-10 14:49 PST by Boris Zbarsky [:bz] (Out June 25-July 6)
Modified: 2012-02-22 10:40 PST (History)
2 users (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add a JS_GetFunctionPrototype API for getting the canonical Function.prototype. (1.92 KB, patch)
2012-02-10 14:52 PST, Boris Zbarsky [:bz] (Out June 25-July 6)
dmandelin: review+
jwalden+bmo: review+
Details | Diff | Review

Description Boris Zbarsky [:bz] (Out June 25-July 6) 2012-02-10 14:49:04 PST
I need this for new DOM bindings.
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-02-10 14:52:03 PST
Created attachment 596179 [details] [diff] [review]
Add a JS_GetFunctionPrototype API for getting the canonical Function.prototype.
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2012-02-10 14:59:42 PST
Comment on attachment 596179 [details] [diff] [review]
Add a JS_GetFunctionPrototype API for getting the canonical Function.prototype.

Looks fine, since it's JSAPI you should also run it past dmandelin -- redirecting to him.  If time's super-urgent I'm confident enough in this that you could probably land and get retroactive review, although I'm guessing it's not that super-urgent.
Comment 3 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-02-10 15:27:40 PST
I already landed this on the repo I'm actually working in.  So I'm not blocked on this; I'd just rather get it on inbound on its own, not as part of a megapatch.
Comment 4 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-02-21 15:03:43 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/15568430f7f4
Comment 5 Ed Morley [:emorley] 2012-02-22 10:40:21 PST
https://hg.mozilla.org/mozilla-central/rev/15568430f7f4

Note You need to log in before you can comment on or make changes to this bug.