Last Comment Bug 726189 - get rid of search engine "used" attribute, since it causes unnecessary I/O
: get rid of search engine "used" attribute, since it causes unnecessary I/O
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Search (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Raymond Lee [:raymondlee]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-10 15:06 PST by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2012-05-26 05:21 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (2.49 KB, patch)
2012-05-21 23:45 PDT, Raymond Lee [:raymondlee]
gavin.sharp: review+
Details | Diff | Splinter Review
Patch for checkin (2.77 KB, patch)
2012-05-23 21:00 PDT, Raymond Lee [:raymondlee]
no flags Details | Diff | Splinter Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-10 15:06:04 PST
Bug 467890 added a "used" annotation in engineMetaDataService to support tracking the first-use of default search plugins, so that we can trigger an update check. We haven't made use of that functionality (bug 511017), and in the mean time, this is causing us to hit the disk the first time a default search engine is used. and also increasing the odds of needing to write metadata, since it's the only use of the engineMetaDataService that's triggered by a common user action (simply using the search bar).

I think we should get rid of the "used" attribute for the moment. It's easy to re-introduce if we ever do end up investing in the work required to complete bug 511017.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-29 12:15:57 PST
The changeset that added it:
http://hg.mozilla.org/mozilla-central/rev/ecba698e87b5
Comment 2 Raymond Lee [:raymondlee] 2012-05-21 23:45:44 PDT
Created attachment 625906 [details] [diff] [review]
v1
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-05-22 11:10:16 PDT
Comment on attachment 625906 [details] [diff] [review]
v1

Thanks!
Comment 4 Raymond Lee [:raymondlee] 2012-05-23 21:00:17 PDT
Created attachment 626686 [details] [diff] [review]
Patch for checkin

Pushed to try and waiting for results
https://tbpl.mozilla.org/?tree=Try&rev=84b3c632fa1d
Comment 5 Raymond Lee [:raymondlee] 2012-05-24 20:27:12 PDT
Passed Try
Comment 6 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2012-05-25 12:30:02 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/611663a9cb81
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-05-26 05:21:02 PDT
https://hg.mozilla.org/mozilla-central/rev/611663a9cb81

Note You need to log in before you can comment on or make changes to this bug.