[meta] B2G RIL: akami support

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: fabrice, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Reporter)

Description

7 years ago
Here's the startup log when turning DEBUG to true in the ril worker.

Nothing more from the RIL afterward.

I/Gecko   (  275): RIL Worker: Received 16 bytes.
I/Gecko   (  275): RIL Worker: Already read 0
I/Gecko   (  275): RIL Worker: New incoming parcel of size 12
I/Gecko   (  275): RIL Worker: Parcel (size 12): 1,0,0,0,232,3,0,0,1,0,0,0
I/Gecko   (  275): RIL Worker: We have at least one complete parcel.
I/Gecko   (  275): RIL Worker: Unsolicited response for request type 1000
I/Gecko   (  275): RIL Worker: Handling parcel as UNSOLICITED_RESPONSE_RADIO_STATE_CHANGED
I/Gecko   (  275): RIL Worker: Radio state changed from 1 to 1
I/Gecko   (  275): RIL Worker: Next parcel size unknown, going to sleep.
(Reporter)

Updated

7 years ago
Assignee: nobody → kyle
I can't seem to repro this. I've got a SIM card in and am seeing status updates about radio strength just fine (as in it's actually showing strength updates not just 99's.)
Status: NEW → UNCONFIRMED
Ever confirmed: false
Ok something is definitely up at least. I can't get SMS messages thru to it.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
It doesn't look like we're registering on the network correctly.

I/Gecko   (   82): RIL Worker: New incoming parcel of size 28
I/Gecko   (   82): RIL Worker: Parcel (size 28): 0,0,0,0,67,1,0,0,0,0,0,0,3,0,0,0,255,255,255,255,255,255,255,255,255,255,255,255
I/Gecko   (   82): RIL Worker: We have at least one complete parcel.
I/Gecko   (   82): RIL Worker: Solicited response for request type 22, token 323
I/Gecko   (   82): RIL Worker: Handling parcel as REQUEST_OPERATOR
I/Gecko   (   82): RIL Worker: Next parcel size unknown, going to sleep.

That operator message should be showing us AT&T (for the sim card I have in). However that 0x3 15 bytes down is signifying an error. So this is two bugs: We don't properly pick up operator errors, and the akami doesn't work.
I don't think that's right, Kyle. Deconstructing your parcel from above:

0,0,0,0,    // RESPONSE_TYPE_SOLICITED
67,1,0,0,   // token
0,0,0,0,    // error (none)
3,0,0,0,    // string list with 3 elements
255,255,255,255,255,255,255,255,255,255,255,255 // WTF?!?

Something's definitely fishy here, and the problem seems to be with akami's RIL. Any other clues from the logcat?
Looks like there may be firmware issues out of our control. Leaving open until we have a resolution, but not expecting patches landing via this.
Summary: ril not working properly on akami → [b2g] ril not working properly on akami
This is almost certainly due to the modem being configured for DSDS and Gecko is not initializing the DSDS ril correctly.  Next week I can tweak the modem back to single SIM mode and this issue should be resolved.  I've done this for my Akami and am able to make calls.
Depends on: 728886
Seems like the big issues are resolved with the modem tweaks Michael mentioned. Morphing this bug to track any outstanding RIL issues on the akami.
Assignee: kyle → nobody
Status: ASSIGNED → NEW
Component: General → DOM: Device Interfaces
Product: Boot2Gecko → Core
QA Contact: general → device-interfaces
Summary: [b2g] ril not working properly on akami → [meta] B2G RIL: akami support
Depends on: 744306
Depends on: 745692

Comment 8

6 years ago
Blocks a blocker and depends on a blocker.
blocking-basecamp: --- → ?

Comment 9

6 years ago
Nothing Akami blocks basecamp now.
blocking-basecamp: ? → -
Removing product phone metabug dependency.
No longer blocks: 710489
Component: DOM: Device Interfaces → RIL
Product: Core → Boot2Gecko
Close as all dependencies fixed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.