Closed Bug 726270 Opened 9 years ago Closed 9 years ago

java.lang.NullPointerException: at android.widget.CursorTreeAdapter.setChildrenCursor(CursorTreeAdapter.java)

Categories

(Firefox for Android Graveyard :: General, defect, P1)

13 Branch
ARM
Android
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: scoobidiver, Assigned: Margaret)

References

Details

(Keywords: crash, regression, topcrash, Whiteboard: [native-crash])

Crash Data

Crash Signature: [@ java.lang.NullPointerException: at android.widget.CursorTreeAdapter.setChildrenCursor(CursorTreeAdapter.java) ] → [@ java.lang.NullPointerException: at android.widget.CursorTreeAdapter.setChildrenCursor(CursorTreeAdapter.java) ] [@ java.lang.NullPointerException: at android.widget.CursorTreeAdapter.setChildrenCursor(CursorTreeAdapter.java)]
Whiteboard: [native-crash]
tracking-fennec: --- → ?
This sounds like it may be a regression from bug 716918, but other patches have landed touching that code since then. Is there a way to get a java stack?
"java.lang.NullPointerException
	at android.widget.CursorTreeAdapter.setChildrenCursor(CursorTreeAdapter.java:165)
	at org.mozilla.gecko.AwesomeBarTabs$RefreshChildrenCursorTask.onPostExecute(AwesomeBarTabs.java:224)
	at org.mozilla.gecko.AwesomeBarTabs$RefreshChildrenCursorTask.onPostExecute(AwesomeBarTabs.java:203)
	at android.os.AsyncTask.finish(AsyncTask.java:417)
	at android.os.AsyncTask.access$300(AsyncTask.java:127)
	at android.os.AsyncTask$InternalHandler.handleMessage(AsyncTask.java:429)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:130)
	at org.mozilla.gecko.GeckoApp$32.run(GeckoApp.java:1783)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:130)
	at android.app.ActivityThread.main(ActivityThread.java:3728)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:864)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:622)
	at dalvik.system.NativeStart.main(Native Method)
Assignee: nobody → margaret.leibovic
Lucas, is it possible that childrenCursor can be null here?

http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/AwesomeBarTabs.java#224
It's #3 top crasher in 13.0a1 and #1 without fixed crashers.

The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4b9608fd670c&tochange=7c0ba1c98ff7
bug 716918 belongs to this range. Let's mark this bug as a regression from it.
Blocks: 716918
Keywords: topcrash
(In reply to Margaret Leibovic [:margaret] from comment #3)
> Lucas, is it possible that childrenCursor can be null here?
> 
> http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/
> AwesomeBarTabs.java#224

Nope. The only reason childrenCursor would be null here is when getDesktopBookmarks() returns null. Maybe double check for edge cases on the query itself?
This crash will go away when bug 722020 lands, since we won't be using a CursorTreeAdapter anymore. Hopefully we can finish that soon.
Depends on: 722020
Duplicate of this bug: 728384
Priority: -- → P1
tracking-fennec: ? → ---
I'm marking this as FIXED, since this code is gone now that bug 722020 landed.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.