Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 726303 - Poor radial gradient performance, slow repaint
: Poor radial gradient performance, slow repaint
Status: RESOLVED DUPLICATE of bug 632324
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 13 Branch
: x86_64 Windows 7
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Milan Sreckovic [:milan]
Depends on:
  Show dependency treegraph
Reported: 2012-02-11 07:28 PST by Daniel
Modified: 2013-01-24 05:41 PST (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

slow-radial-gradient.html (442 bytes, text/html)
2012-02-11 07:28 PST, Daniel
no flags Details

Description Daniel 2012-02-11 07:28:55 PST
Created attachment 596324 [details]

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120210 Firefox/13.0a1
Build ID: 20120210031150

Steps to reproduce:

Opening the attached file makes the whole browser lag for me, and resizing the window once opened is very slow. The page has a tiled radial gradient as body background.

The performance on Opera and Google Chrome is excellent on my system. 

I found the issue while looking through some old experiments of mine. It was reasonably snappy back when I first created the page (May 2011) and that makes me think it is a regression. Additionally, the original page had four layered radial gradient backgrounds, which only would have made it worse.

I tested in Firefox 10 and Nightly (13)
Comment 1 Matthias Versen [:Matti] 2012-02-11 09:03:35 PST
Last good nightly: 2010-08-17
First bad nightly: 2010-08-18


Could be "42545f8d4b10	Bas Schouten — Enable D2D by default again." and it works faster in the Firefox safemode (HWA disabled)
Comment 2 Bas Schouten (:bas.schouten) 2012-02-11 09:10:38 PST

*** This bug has been marked as a duplicate of bug 632324 ***

Note You need to log in before you can comment on or make changes to this bug.