Last Comment Bug 726416 - Fix some content/ build warnings
: Fix some content/ build warnings
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2012-02-12 03:30 PST by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-02-21 11:02 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (6.59 KB, patch)
2012-02-12 03:30 PST, :Ms2ger (⌚ UTC+1/+2)
mounir: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-02-12 03:30:10 PST
Created attachment 596447 [details] [diff] [review]
Patch v1
Comment 1 Mounir Lamouri (:mounir) 2012-02-12 14:10:27 PST
Comment on attachment 596447 [details] [diff] [review]
Patch v1

Review of attachment 596447 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the comment addressed

::: content/media/nsBuiltinDecoder.cpp
@@ +326,5 @@
>    // http://www.whatwg.org/specs/web-apps/current-work/multipage/the-video-element.html#seeking
>    PRInt32 range = 0;
>    if (!IsInRanges(seekable, aTime, range)) {
>      if (range != -1) {
> +      if (PRUint32(range + 1) < length) {

Could you just add a comment saying that |range + 1| can't be negative because |range| minimal value is -1? Otherwise, that conversion would be dangerous.
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-02-21 11:02:23 PST
https://hg.mozilla.org/mozilla-central/rev/254285dbf954

Note You need to log in before you can comment on or make changes to this bug.