The default bug view has changed. See this FAQ.

The star panel should not replace the header with itself each time it's opened

RESOLVED FIXED in Firefox 13

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Assigned: mak)

Tracking

(Depends on: 1 bug, {regression})

Trunk
Firefox 13
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/d71dab82fff4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120211 Firefox/13.0a1 ID:20120211031145

Header label of "Edit bookmarks panel" does not change till restart browser.
The header label should be "Page Bookmarked" or "Edit This Bookmark" depending on state of bookmark.

Reproducible: Always

Steps to Reproduce#1:
1. Start Firefox with new profile
2. Open non bookmarked page
3. CTRL+D  ---- you see "Page Bookmarked" as expected
4, Double Click STAR UI

Actual Results:
  The header label is "Page Bookmarked"

Expected Results:
  The header label should be "Edit This Bookmark"


Steps to Reproduce#2:
1. Start Firefox with new profile
2. Open a bookmarked page
3. Double Click STAR UI  ---- you see "Edit This Bookmark" as expected
4. Open non bookmarked page
5. CTRL+D


Actual Results:
  The header label is "Edit This Bookmark"

Expected Results:
  The header label should be "Page Bookmarked"

Regression window(cachedm-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/7aa58a99a2e5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110630 Firefox/7.0a1 ID:20110630003937
Fails:
http://hg.mozilla.org/mozilla-central/rev/5c246f2bccb1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110630 Firefox/7.0a1 ID:20110630035829
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7aa58a99a2e5&tochange=5c246f2bccb1


Regression window(cached m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6777320f6f29
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110629 Firefox/7.0a1 ID:20110629215351
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c2f48684b9f5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110629 Firefox/7.0a1 ID:20110629231921
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6777320f6f29&tochange=c2f48684b9f5


In local build:
first bad changeset c2f48684b9f5
last good changeset fb03584dd823
(Reporter)

Updated

5 years ago
See Also: → bug 725784
(Reporter)

Comment 1

5 years ago
Created attachment 596493 [details] [diff] [review]
possible fix

using setAttribute to set value strings
(Reporter)

Updated

5 years ago
OS: Windows 7 → All
(Assignee)

Updated

5 years ago
Depends on: 725784
(Assignee)

Updated

5 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Component: DOM → Bookmarks & History
Product: Core → Firefox
QA Contact: general → bookmarks
(Assignee)

Updated

5 years ago
Summary: Header label of "Edit bookmarks panel" does not change till restart browser → The star panel should not replace the header with itself each time it's opened
(Assignee)

Comment 2

5 years ago
Comment on attachment 596493 [details] [diff] [review]
possible fix

Will shortly attach a patch that avoid the self replacement, since it was a no-op but now it's not anymore. We don't need to pay that cost.

Btw, would like to thank you for finding these bugs and the problem.
Attachment #596493 - Attachment is obsolete: true
(Assignee)

Comment 3

5 years ago
Created attachment 600035 [details] [diff] [review]
patch v1.0

So basically, instead of moving it each time the panel is opened, this moves it when the binding is lazy loaded on first opening.
Attachment #600035 - Flags: review?(dietrich)
Attachment #600035 - Flags: review?(dietrich) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4e2e861f136b
Target Milestone: --- → Firefox 13
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/4e2e861f136b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Blocks: 638785

Updated

5 years ago
Blocks: 763708
You need to log in before you can comment on or make changes to this bug.