Last Comment Bug 726474 - Exiting fullscreen by clicking in other monitor breaks re-entering fullscreen
: Exiting fullscreen by clicking in other monitor breaks re-entering fullscreen
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: 11 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Chris Pearce (:cpearce)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 729872
Blocks: 545812 706672
  Show dependency treegraph
 
Reported: 2012-02-12 14:14 PST by Chris Pearce (:cpearce)
Modified: 2012-03-06 09:39 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Chris Pearce (:cpearce) 2012-02-12 14:14:57 PST
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120212 Firefox/13.0a1

STR (requires dual monitor setup):
1. Load http://pearce.org.nz/full-screen/
2. Press 'f' key to enter fullscreen.
3. Click on the desktop in your other monitor, fullscreen will exit.
4. Focus the browser window again and press 'f', a fullscreenerror will be thrown.

In the webconsole the following error is logged:
"Request for full-screen was denied because requesting element is not in the currently focused tab."

Problem doesn't occur in FF10.0.1 [Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1], though I can't focus the chrome UI after following the STR above (possibly related to 718939?).
Comment 1 Chris Pearce (:cpearce) 2012-02-12 14:36:49 PST
Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d75ebb37080e&tochange=2afd7ae68e8b

Most likely a regression from bug 706672, which merged to m-c in that range.
Comment 2 Chris Pearce (:cpearce) 2012-03-05 13:35:14 PST
This should be fixed by bug 706672.

Note You need to log in before you can comment on or make changes to this bug.