Last Comment Bug 726485 - Add-on SDK leaks compartments (with MemChaser installed)
: Add-on SDK leaks compartments (with MemChaser installed)
Status: RESOLVED FIXED
[MemShrink:P3]
: mlk
Product: Add-on SDK
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 724404 724433
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-12 16:02 PST by Henrik Skupin (:whimboo)
Modified: 2012-04-12 11:51 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Henrik Skupin (:whimboo) 2012-02-12 16:02:46 PST
We got a report that MemChaser leaks a lot of cuddlefish.js compartments. Those are still around even if the extension has been disabled or removed. It sounds similar to bug 725603 but we mainly require different modules. Also the patch on bug 724433 doesn't actually solve the problem for us. So I have disabled the require widgets line in main.js because of bug 724404, but that also made no difference.

That's why I file this as a new bug for now. Whenever an improvement lands we will make sure to test our extension again.
Comment 1 Henrik Skupin (:whimboo) 2012-02-14 08:01:22 PST
So I will make this more general because it's not only cuddlefish.js which is leaking. With bug 724433 the situation has already been improved massively. But there are still compartments lingering around when disabling MemChaser.

│  ├───2,407,696 B (03.59%) -- compartment([System Principal], resource://memchaser-at-quality-dot-mozilla-dot-org/api-utils/lib/environment.js, 0x1133a9000)
│  ├─────822,384 B (01.23%) -- compartment([System Principal], resource://memchaser-at-quality-dot-mozilla-dot-org/api-utils/lib/environment.js, 0x1080b9000)
│  ├─────192,304 B (00.24%) -- compartment([System Principal], jar:file:///var/folders/wd/zmy4z7xn7wd7sjq90z1y52f80000gn/T/tmp08VsmH.mozrunner/extensions/memchaser@quality.mozilla.org.xpi!/bootstrap.js, 0x107dc7000)

Alex, shall I file separate bugs for those issues or can we take care of here?
Comment 2 Alexandre Poirot [:ochameau] PTO, back on 1st 2012-02-15 07:02:45 PST
No, we can provide specific patch here, if bugs 724433 and 724404 doesn't address all leaks.
Comment 3 Henrik Skupin (:whimboo) 2012-02-15 16:00:15 PST
Any compartment of MemChaser is now removed when disabling the extension. So everything is fine now. Thanks for those quick fixes!
Comment 4 Danial Horton 2012-03-16 22:13:19 PDT
nope, still occurs

memchaser-at-quality-dot-mozilla-dot-org/api-utils/lib/environment.js compartment still exists after disabling the extension.
Comment 5 Wes Kocher (:KWierso) 2012-03-16 22:24:18 PDT
Indeed.
Comment 6 Henrik Skupin (:whimboo) 2012-03-17 05:13:54 PDT
Daniel, which version of the SDK are you using?
Comment 7 Alexandre Poirot [:ochameau] PTO, back on 1st 2012-04-05 06:35:50 PDT
Danial, Henrik, 
Do you confirm that all leaks are now gone in 1.6 ?
I just tested memchaser with master head against SDK master head.
And I clicked on all possible actions of memchaser, then disabled it and haven't seen any leftover compartments.
(btw, I now clearly understand your request about widget on panel position on pointer ;))
Comment 8 Henrik Skupin (:whimboo) 2012-04-10 08:28:43 PDT
As I have mentioned earlier I'm not able to reproduce any of the leaks as mentioned in this bug anymore with the SDK 1.6. So not sure which version of the SDK Danial was using when testing it. Doesn't look like the 1.6 one.

Closing the bug again given that it works and we never got more information from Danial.

Note You need to log in before you can comment on or make changes to this bug.