Closed Bug 726537 Opened 8 years ago Closed 8 years ago

Character '\' is saved in bookmarks as "%5C"

Categories

(Firefox :: Bookmarks & History, defect)

3.6 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: zepi30, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16 GTB7.1 ; eSafeUser=Belzanti_r;
Build ID: 20110319135224

Steps to reproduce:

I saved as bookmark a page that has an URL containing a '\' character.


Actual results:

The bookmark is saved with an URL that doesn't matches the saved one. The consequence is that when i load a page using the bookmark, the page is loaded with the wrong URL.


Expected results:

Instead of loading a page with an URL like :
"https://teletest.mySociety.fr/msgc-001/msgc11/\myName.nsf?Opendatabase&ui=Inotes"
The page is loaded with this URL :
https://teletest.mySociety.fr/msgc-001/msgc11/%5CmyName.nsf?Opendatabase&ui=Inotes"

When i load the page, the website redirect me to a logging page and then, when i'm authentified/identified, i'm redirected to the URL i asked for. The problem is that i get a 404 error due to the fact that the URL contains a '%5C' instead of a '\'.

Thank you.
Component: Untriaged → Bookmarks & History
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: backslash
QA Contact: untriaged → bookmarks
You need to log in before you can comment on or make changes to this bug.