open location entry widget allows newlines; problems with delete behaviour

VERIFIED WORKSFORME

Status

()

Core
Editor
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Joel Becker, Assigned: rubydoo123)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When the "Open Web Location" dialog is brought up, it has a single-line entry
widget for typing the new URL.  However, if a URL is pasted that contains a
newline (eg, from an IRC window), the newline is not removed or transformed into
a space as happens on classic navigator and other browsers.  The user can
navigate the multiple lines with the up/down keys, and it is not obvious where
the remaining text is.

The big problem is that backspace/delete do not behave as you would expect, and
therefore allow you to delete text that is off-screen,without seeing what was to
be deleted.  It would be preferrable to just eliminate the newline upon paste,
or to transform it (at least in display) to a space.  As a URL cannot legally
contain newlines, no functionality would be removed.
related to bug 23485

Comment 2

17 years ago
(Damn, Boris is fast). At any rate, I was going to say this is bug 23485, or 
bug 50935. It is controllable by a pref (see bug 50935) to the extent that
you can say "paste only the first line of a multiline clipboard". Difficulties
in navigating the multiline, are, well, a 'feature' of editor at times. 

duping against 23485 

*** This bug has been marked as a duplicate of 23485 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
What's the bug for the delete-at-end-of-newline insanity?  It needs attention.

Comment 4

17 years ago
I don't particularly know ...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

17 years ago
-> editor, to find the dup if it exists.
Assignee: trudelle → beppe
Status: UNCONFIRMED → NEW
Component: XP Toolkit/Widgets → Editor
Ever confirmed: true
QA Contact: jrgm → sujay
Summary: open location entry widget allows newlines → open location entry widget allows newlines; problems with delete behaviour
(Assignee)

Comment 6

17 years ago
yes, this is a pref. please check:
http://www.mozilla.org/unix/customizing.html#prefs

and you will be able to get the effect that you are looking for after you make 
the change:
// Newline paste behavior: 0=paste unchanged, 1=paste only
// first line, 2=replace with spaces, 3=strip newlines
//user_pref("editor.singleLine.pasteNewlines", 0);
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

17 years ago
That is certainly a nice preference, and would go many strides towards solving
my problem, but it does not appear to work in my 2001030913 build.  Is this a
new preference?

Comment 8

17 years ago
No, it's been around for many months.
The pref works for me in today's build.

Comment 9

17 years ago
verified in 3/21 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.