The default bug view has changed. See this FAQ.

<canvas> clip with shadowBlur, has vertical offset

RESOLVED FIXED in mozilla13

Status

()

Core
Canvas: 2D
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: david berneda, Assigned: bas)

Tracking

({regression})

unspecified
mozilla13
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox10-, firefox11-)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 596954 [details]
canvas_clip_shadow.htm

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7

Steps to reproduce:

Applying a rectangular clip, then drawing content with shadowblur over the clipped rectangle.  See attachment, click the "Clip" checkbox.


Actual results:

The clipped rectangle seems to be vertically offset by a value aprox twice the shadowOffsetY.


Expected results:

Clipped rectangle should respect shadow parameters. When no shadow is applied, clipping works fine.

Updated

5 years ago
Attachment #596954 - Attachment mime type: text/plain → text/html

Comment 1

5 years ago
Confirmed on
http://hg.mozilla.org/mozilla-central/rev/60edf587f4af
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120214 Firefox/13.0a1 ID:20120214031227

This does not happens on ubuntu
http://hg.mozilla.org/mozilla-central/rev/60edf587f4af
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120214 Firefox/13.0a1 ID:20120214031227

Regression window(cached m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/2b9a669880df
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110713 Firefox/8.0a1 ID:20110713140256
Fails:
http://hg.mozilla.org/mozilla-central/rev/4162bda16a6a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110713 Firefox/8.0a1 ID:20110713142700
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2b9a669880df&tochange=4162bda16a6a


Regression window(cached m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/0f18324ce229
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110712 Firefox/8.0a1 ID:20110712150650
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e703f4342489
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110713 Firefox/8.0a1 ID:20110713010015
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0f18324ce229&tochange=e703f43
42489

Suspected: Bug 666452
Blocks: 666452
Keywords: regression
Hardware: x86_64 → x86

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

5 years ago
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED
(Assignee)

Comment 2

5 years ago
Created attachment 597066 [details] [diff] [review]
Correctly use height to normalize v texture coordinate.
Attachment #597066 - Flags: review?(jmuizelaar)
(Assignee)

Updated

5 years ago
tracking-firefox10: --- → ?
tracking-firefox11: --- → ?
Reftest please
(Assignee)

Comment 4

5 years ago
Created attachment 597282 [details] [diff] [review]
Test for shadow clips working correctly on non-rectangular canvases
Attachment #597282 - Flags: review?(jmuizelaar)
Attachment #597066 - Flags: review?(jmuizelaar) → review+
Comment on attachment 597282 [details] [diff] [review]
Test for shadow clips working correctly on non-rectangular canvases

A better test name like 726951-shadow-clips.html would be nice
Attachment #597282 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/274121fbd839
https://hg.mozilla.org/integration/mozilla-inbound/rev/161ce815ab79
https://hg.mozilla.org/mozilla-central/rev/274121fbd839
https://hg.mozilla.org/mozilla-central/rev/161ce815ab79
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13

Comment 8

5 years ago
This is a regression from FF8 (according to comment#1), and we have zero dupes, so I don't think this needs to be tracked for FF10 and up. Please nominate for Aurora/Beta approval if you disagree and feel there's ample reason to uplift.
tracking-firefox10: ? → -
tracking-firefox11: ? → -
(Assignee)

Comment 9

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #8)
> This is a regression from FF8 (according to comment#1), and we have zero
> dupes, so I don't think this needs to be tracked for FF10 and up. Please
> nominate for Aurora/Beta approval if you disagree and feel there's ample
> reason to uplift.

I don't really mind either way, the only reason to uplift this might be that it's -extremely- low-risk.
You need to log in before you can comment on or make changes to this bug.