Last Comment Bug 726986 - GCLI help output should be better
: GCLI help output should be better
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: All All
: P2 normal (vote)
: Firefox 15
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
Mentors:
: 725237 (view as bug list)
Depends on: 760115
Blocks: 745773 758599
  Show dependency treegraph
 
Reported: 2012-02-14 05:45 PST by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-05-31 07:50 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Upload 1 (10.32 KB, patch)
2012-05-22 14:14 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
no flags Details | Diff | Review
Upload 2 (13.26 KB, patch)
2012-05-29 09:07 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
dcamp: review+
Details | Diff | Review

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-02-14 05:45:33 PST
1. Asking for help on a command with sub-commands should list the sub-commands
2. Double-click to execute directly should be more of the norm
3. There's a typo in one of the strings for the pref command
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-04-29 10:27:24 PDT
GCLI Triage.
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-22 13:00:30 PDT
*** Bug 725237 has been marked as a duplicate of this bug. ***
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-22 14:14:41 PDT
Created attachment 626179 [details] [diff] [review]
Upload 1

a.k.a https://github.com/campd/gcli/pull/44
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-23 02:01:17 PDT
https://tbpl.mozilla.org/?tree=Try&rev=ff9aee3c9f35
Comment 5 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-29 06:35:18 PDT
https://tbpl.mozilla.org/?tree=Try&rev=0986bf634f72
Comment 6 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-29 09:07:58 PDT
Created attachment 627983 [details] [diff] [review]
Upload 2
Comment 7 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-29 11:31:56 PDT
https://tbpl.mozilla.org/?tree=Try&rev=77f745e77098
Comment 8 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-30 01:05:37 PDT
https://tbpl.mozilla.org/?tree=Fx-Team&rev=7df3e6796d1f
Comment 9 Dave Camp (:dcamp) 2012-05-30 19:31:52 PDT
https://hg.mozilla.org/mozilla-central/rev/f8eab657c0ff

Note You need to log in before you can comment on or make changes to this bug.