Bugzilla form contents not restored after using back button if commit has error

VERIFIED DUPLICATE of bug 74639

Status

()

P3
major
VERIFIED DUPLICATE of bug 74639
18 years ago
10 years ago

People

(Reporter: cmanske, Assigned: radha)

Tracking

Trunk
mozilla0.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Load a bugzilla report page in browser.
Type some sample comments in the "Description" field.
Type some bad text such as "badbadbad" in the Keywords field.
Click the Commit button.
You will get the error message that the keyword wasn't recognized.
Use browser's Back button to go back to your page.
Contents in Desctiption field are lost.
Expected result: All of the textfields should contain the same values as they
did before you used "Commit".

I also see this behavior when there is a "midair collision" message because
someone else has commited a change before you.
I also tried using an unrecognized email address in the "CC" field, but in
that case the description was restored ok.
Obviously this is very annoying if you've typed a long and detailed
description for a bug!
Claudius, can you try this out and provide an update. I'm not sure if there is a
specific problem with the "keywords" form element in bugzilla.
Component: Browser-General → History: Session
Priority: -- → P3
QA Contact: doronr → claudius
Target Milestone: --- → mozilla0.9.1

Comment 2

18 years ago
the trouble does not seem to be anything specific with the 'keyword' form field.
With a  2001032708 Linux build I attempted to make invalid changes in the 'Add CC',
'QA Contact', and 'keyword' fields combined with an addition to the 'Comments' text field.

In each case I received the bugzilla error page and was told to 'go back'. Upon doing so, I
noted that in each case the 'Comments' text field was blank AND the invalid change I made
was also missing.

This is contrary to 4.x behavior. In that case, after clicking back I was returned to the page as
I left it - comments in the text field AND my invalid changes stood before me, ie all form elements
as I attempted to submit them.
OS: Windows NT → All
Marking this dupe of 74639. Thet bug has more people cc'ed on it. I will add 
cmanske to the cc list of that bug. 

*** This bug has been marked as a duplicate of 74639 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
The orginal bug has been fixed. Marking verified.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.