status bar not updating properly

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Sam Rowe, Assigned: jag (Peter Annema))

Tracking

Trunk
mozilla1.1alpha
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1 i686; en-US; 0.8.1) Gecko/20010320
BuildID:    Mozilla/5.0 (X11; U; Linux 2.4.1 i686; en-US; 0.8.1) Gecko/20010320

Might be a dupe of http://bugzilla.mozilla.org/show_bug.cgi?id=47579 but is
different enough that I thought I should report it.

The status bar doesn't update properly when given a Location: header.

Reproducible: Always
Steps to Reproduce:
1.create a file on 127.0.0.1 that sends a location header to somewhere else
2.load that file
3.look at status bar :)

Actual Results:  The status bar will say "Resolving 127.0.0.1" when it's really
resolving the new Location.

Comment 1

17 years ago
jag? session related? xpapps qa?
Assignee: asa → disttsc
Component: Browser-General → History: Session
QA Contact: doronr → sairuh

Comment 2

17 years ago
Nah, I suspect this is because of the 400ms timeout in navigator.js

Definitely the wrong component though.
Component: History: Session → XP Apps
Target Milestone: --- → mozilla1.0
->claudius for qa, i think. not sure of the component if this isn't the right one...
QA Contact: sairuh → claudius
(Reporter)

Comment 4

17 years ago
This extends beyond the status bar. If Mozilla is unable to resolve the new
domain, it'll give an error dialog saying "127.0.0.1 could not be found. Please
check the name and try again."

Comment 5

17 years ago
redirected requests carry with them the original URI, so this dialog could
just be displaying the original URI.
(Reporter)

Comment 6

17 years ago
Which is why I submitted the bug?

Comment 7

17 years ago
Yeah, but a bug can have many causes and it sometimes can take a while to figure
out what it is :-)

Comment 8

17 years ago
can anyone confirm this? If not it'll just sit here because it's useless to pass around a bug
(searching for the proper owner)until it's been confirmed(and I dunno how).
(Reporter)

Comment 9

17 years ago
Well, for what it's worth, I discovered it using http://www.deadman.org/redirect/

My intention is not to spam.

Comment 10

17 years ago
Mass move to jaggernaut@netscape.com
Assignee: jag → jaggernaut

Comment 11

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 12

16 years ago
Is this still an issue? -> 1.1 for now
Target Milestone: mozilla1.0 → mozilla1.1
(Reporter)

Comment 13

16 years ago
Yes. Still an issue. I'd call it dogfood. It's one of the first things people
(web dorks^H^H^H^H developers) notice. 

I can't believe it's still a problem and I can't believe Moz'll be 1.0 with it
still broken.
(Reporter)

Comment 14

16 years ago
This works now.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.