Last Comment Bug 727221 - mark LastDictionary and nsElementDeletionObserver final
: mark LastDictionary and nsElementDeletionObserver final
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla13
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
: Makoto Kato [:m_kato]
Mentors:
Depends on:
Blocks: clang
  Show dependency treegraph
 
Reported: 2012-02-14 12:59 PST by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2012-02-17 05:34 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
mark LastDictionary and nsElementDeletionObserver final (1.05 KB, patch)
2012-02-14 12:59 PST, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
ehsan: review+
Details | Diff | Splinter Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-14 12:59:29 PST
Created attachment 597147 [details] [diff] [review]
mark LastDictionary and nsElementDeletionObserver final

This fixes an error with clang and -Werror since these classes are deleted and have virtual methods.
Comment 1 :Ehsan Akhgari 2012-02-16 06:37:41 PST
Comment on attachment 597147 [details] [diff] [review]
mark LastDictionary and nsElementDeletionObserver final

r=me.
Comment 2 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-16 06:41:35 PST
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=201cdcb16256
Comment 3 Ed Morley [:emorley] 2012-02-17 05:34:00 PST
https://hg.mozilla.org/mozilla-central/rev/201cdcb16256

Note You need to log in before you can comment on or make changes to this bug.