Last Comment Bug 727222 - mark some classes in content/html/content/src/ final
: mark some classes in content/html/content/src/ final
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla13
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-14 13:05 PST by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2012-02-16 02:54 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
mark some classes in content/html/content/src/ final (3.65 KB, patch)
2012-02-14 13:05 PST, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
bugs: review+
Details | Diff | Splinter Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-14 13:05:14 PST
Created attachment 597150 [details] [diff] [review]
mark some classes in content/html/content/src/ final

This fixes errors in a clang build with -Werror since we delete these classes and they have virtual methods but no virtual destructor.
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-15 07:44:02 PST
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=e8080560b547
Comment 2 Marco Bonardo [::mak] 2012-02-16 02:54:19 PST
https://hg.mozilla.org/mozilla-central/rev/e8080560b547

Note You need to log in before you can comment on or make changes to this bug.