Last Comment Bug 727226 - mark some classes in content/canvas/src final
: mark some classes in content/canvas/src final
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla13
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
Mentors:
Depends on:
Blocks: clang
  Show dependency treegraph
 
Reported: 2012-02-14 13:10 PST by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2012-02-17 05:35 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
mark some classes in content/canvas/src final (3.25 KB, patch)
2012-02-14 13:10 PST, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
jmuizelaar: review+
Details | Diff | Splinter Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-14 13:10:30 PST
Created attachment 597152 [details] [diff] [review]
mark some classes in content/canvas/src final

This fixes some errors in a clang build with -Werror because these classes are deleted and have virtual methods but not a virtual destructor.
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-16 05:25:56 PST
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=41f544c64c46
Comment 2 Ed Morley [:emorley] 2012-02-17 05:35:20 PST
https://hg.mozilla.org/mozilla-central/rev/41f544c64c46

Note You need to log in before you can comment on or make changes to this bug.