Last Comment Bug 727233 - don't delete an interface
: don't delete an interface
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Geolocation (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla13
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
Mentors:
Depends on:
Blocks: clang
  Show dependency treegraph
 
Reported: 2012-02-14 13:18 PST by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2012-02-28 09:28 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
don't delete an interface (1.62 KB, patch)
2012-02-14 13:18 PST, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
doug.turner: review+
Details | Diff | Splinter Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-14 13:18:40 PST
Created attachment 597156 [details] [diff] [review]
don't delete an interface

Currently we have a delete of nsIDOMGeoPositionCoords. This breaks -Werror builds with clang and looks very odd.

This patch changes the variables types to use nsGeoPositionCoords instead of nsIDOMGeoPositionCoords. This then requires a static_cast because of the autogenerated GetCoords.
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-16 07:04:21 PST
The delete was introduced in bug 617965. ccing bent who also reviewed it.
Comment 2 Doug Turner (:dougt) 2012-02-17 08:16:45 PST
Comment on attachment 597156 [details] [diff] [review]
don't delete an interface

there is no problem with GeoPositionAddress or GeoPosition?
Comment 3 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-17 08:36:24 PST
(In reply to Doug Turner (:dougt) from comment #2)
> Comment on attachment 597156 [details] [diff] [review]
> don't delete an interface
> 
> there is no problem with GeoPositionAddress or GeoPosition?

We don't call delete on them. So at least there is not this problem :-)
Comment 4 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-27 05:30:00 PST
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=f91b74bfcb1f
Comment 5 Matt Brubeck (:mbrubeck) 2012-02-28 09:28:04 PST
https://hg.mozilla.org/mozilla-central/rev/f91b74bfcb1f

Note You need to log in before you can comment on or make changes to this bug.