Last Comment Bug 727244 - dragging a link onto a tab results in a JS exception: Error: "draggedTab is undefined"
: dragging a link onto a tab results in a JS exception: Error: "draggedTab is u...
Status: VERIFIED FIXED
[qa!]
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 13
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-14 14:00 PST by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2013-11-12 00:56 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified


Attachments
patch (1.15 KB, patch)
2012-02-14 14:00 PST, :Gavin Sharp [email: gavin@gavinsharp.com]
fryn: review+
Details | Diff | Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-14 14:00:06 PST
STR:
1) Drag link from content area to the currently selected tab

Expected: link loads in tab, no JS exceptions
Actual: exception fired because draggedTab is undefined in the drop handler:

Error: draggedTab is undefined
Source File: chrome://browser/content/tabbrowser.xml
Line: 3518
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-14 14:00:47 PST
Created attachment 597179 [details] [diff] [review]
patch
Comment 2 Frank Yan (:fryn) 2012-02-14 14:07:19 PST
Comment on attachment 597179 [details] [diff] [review]
patch

A tiny mistake in Jez's patch for bug 465186. No biggie. :)
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-15 12:22:27 PST
https://hg.mozilla.org/mozilla-central/rev/a599bea9935a
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-21 10:58:46 PST
I landed this on aurora/beta since the test for the patch for bug 718203 depends on it:
https://hg.mozilla.org/releases/mozilla-beta/rev/1518b43a6f1b
https://hg.mozilla.org/releases/mozilla-aurora/rev/c00445fcd26d
Comment 5 Ioana (away) 2012-02-24 08:47:39 PST
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 6 Ioana (away) 2012-03-16 07:25:02 PDT
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0
BuildID: 20120314195616

Note You need to log in before you can comment on or make changes to this bug.