The default bug view has changed. See this FAQ.

JS OOM Testing: Assertion failure: verifiedRange, at methodjit/BaseCompiler.h:123

RESOLVED FIXED in mozilla14

Status

()

Core
JavaScript Engine
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: decoder, Unassigned)

Tracking

({assertion, testcase})

Trunk
mozilla14
x86_64
Linux
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: js-triage-needed)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
The following command asserts on mozilla-central revision d45c7d7b0079:

js -m -n -a -A 1777 -f js/src/tests/shell.js -f js/src/tests/ecma/shell.js -f js/src/tests/ecma/Expressions/shell.js -f js/src/tests/ecma/Expressions/11.4.1.js


This could be related to bug 727331, as I hit that assertion afterwards.
Created attachment 613603 [details] [diff] [review]
patch

Bogus assert, if linker initialization fails then its destructor will botch.
Attachment #613603 - Flags: review?(dvander)
Duplicate of this bug: 735046
Attachment #613603 - Flags: review?(dvander) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/a44bebea2bc8
https://hg.mozilla.org/mozilla-central/rev/a44bebea2bc8
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14
You need to log in before you can comment on or make changes to this bug.