Closed Bug 727380 Opened 12 years ago Closed 12 years ago

custom event handler isn't updated if selecting other event

Categories

(Other Applications :: DOM Inspector, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: surkov, Assigned: surkov)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Attached patch patch (obsolete) — Splinter Review
'onchange' approach doesn't work because it's not fired since "blur" and "change" events are fired after focus was handled by tree and handler editor was updated. That's a reason of selection index and handler editor value caching.
Attachment #597323 - Flags: review?(neil)
OS: Mac OS X → All
Hardware: x86 → All
Attached patch patch2Splinter Review
previous patch doesn't fix the problem when you switch to event group (the same reason blur is not fired because tree disables editor on focus). I think be in danger event will be handled before the user finished to write code of event handler is the price we can pay. Actually it doesn't hurt the user because the user is not interested in event until he finished event handler.
Attachment #597323 - Attachment is obsolete: true
Attachment #597332 - Flags: review?(neil)
Attachment #597323 - Flags: review?(neil)
Comment on attachment 597332 [details] [diff] [review]
patch2

Annoying, but fair enough.
Attachment #597332 - Flags: review?(neil) → review+
http://hg.mozilla.org/dom-inspector/rev/578c7a191c9d
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: