performance in javascript-command&conquer is magnitudes worse than in chrome

RESOLVED DUPLICATE of bug 718481

Status

()

RESOLVED DUPLICATE of bug 718481
7 years ago
7 years ago

People

(Reporter: daef, Unassigned)

Tracking

({perf})

12 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a2) Gecko/20120214 Firefox/12.0a2
Build ID: 20120214042008

Steps to reproduce:

open
http://www.adityaravishankar.com/projects/games/command-and-conquer/
and observe performance


Actual results:

it was really slow


Expected results:

it should have been fluid (as in chrome e.g.)
(Reporter)

Updated

7 years ago
(Reporter)

Updated

7 years ago
Component: Untriaged → General
(Reporter)

Updated

7 years ago
Keywords: perf
Just to be sure: have you determined for sure that it is JS speed and not, say, display speed? If so, we can triage this bug to the JS team.

Comment 2

7 years ago
Reproduced (very slow and jerky):
Mozilla/5.0 (X11; Linux x86_64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a2) Gecko/20120214 Firefox/12.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:13.0a1) Gecko/20120215 Firefox/13.0a1

WFM:
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7
Opera/9.80 (X11; Linux x86_64; U; en) Presto/2.10.229 Version/11.61

/usr/bin/X consumes 75% CPU while running Firefox, and Firefox itself 25% CPU.
OS: Windows 7 → All
Version: 12 Branch → Trunk

Comment 3

7 years ago
(In reply to David Rajchenbach Teller [:Yoric] from comment #1)
> Just to be sure: have you determined for sure that it is JS speed and not,
> say, display speed? If so, we can triage this bug to the JS team.

I interpret "javascript-command&conquer" as the bug is about command&conquer written in JavaScript, not necessarily that the bug is in JavaScript itself. The high CPU usage by X in Linux indicates that it's not primarily a JavaScript problem.

Can someone running Windows find out which process makes the computer lag?

Comment 4

7 years ago
/usr/bin/X uses 3 % CPU with Chromium (vs 75% with Linux).

Comment 5

7 years ago
(In reply to Thomas Ahlblom from comment #4)
> /usr/bin/X uses 3 % CPU with Chromium (vs 75% with Linux).

Eeeeh!

…(vs 75 % with Firefox)
(Reporter)

Comment 6

7 years ago
> Can someone running Windows find out which process makes the computer lag?
>
I'm running Windows, on my 4-core i7 firefox.exe uses a constant of 25% overall
(or mashes one core to put it in other words).

Is there a way to inspect the usage more fine-grained?
OS: All → Windows 7
Version: Trunk → 12 Branch
(Reporter)

Comment 7

7 years ago
> Just to be sure: have you determined for sure that it is JS speed and not,
> say, display speed? If so, we can triage this bug to the JS team.
>
nope - what I wanted to say is that the lag occurs when playing around with "js-C&C". I don't really have a clue which part of FF is responsible for that mess :-) might be JS, might be UI, might be anything...

How can one trace where that cycles go?
(Reporter)

Comment 8

7 years ago
y u no reply?

Comment 9

7 years ago
I'm pretty sure bug 718481 has more analysis in it and is therefore more actionable.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 718481

Updated

7 years ago
Component: General → Canvas: 2D
Product: Firefox → Core
QA Contact: untriaged → canvas.2d
You need to log in before you can comment on or make changes to this bug.