Last Comment Bug 727414 - Busy cursor in thread and folderpane while reading news (ui.use_activity_cursor = true)
: Busy cursor in thread and folderpane while reading news (ui.use_activity_curs...
Status: RESOLVED FIXED
[relnote: sm-only]
: regression, relnote
Product: MailNews Core
Classification: Components
Component: Networking: NNTP (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: Thunderbird 24.0
Assigned To: Hartmut Figge
:
Mentors:
: 736505 (view as bug list)
Depends on:
Blocks: 537015
  Show dependency treegraph
 
Reported: 2012-02-15 05:20 PST by stefan.blumenrath
Modified: 2013-06-25 05:19 PDT (History)
23 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
BUG (56.00 KB, text/plain)
2012-06-26 17:38 PDT, martin11
no flags Details
fix try1 [Checkin: Comment 52] (1.22 KB, patch)
2012-12-23 03:01 PST, Hartmut Figge
Pidgeot18: review+
Details | Diff | Splinter Review

Description stefan.blumenrath 2012-02-15 05:20:17 PST
When reading news, I often get a busy cursor in the folder- and threadpane but not in the messagepane when I switch from one newsgroup to another. It seems to happen, when I switch fast from one posting to another, maybe it complains to any message getting downloaded.
This busy cursor won't leave, until I close mailnews.

Errorconsole says: Zeitstempel: 15.02.2012 14:17:04
Warnung: Das totalSize-Attribut von Fortschrittsereignissen in XMLHttpRequest sollte nicht mehr verwendet werden.
Quelldatei: chrome://messenger/content/messenger.xul
Zeile: 0
Comment 1 Philip Chee 2012-02-15 07:14:37 PST
Sounds like an extension is causing the message. Try restarting SeaMonkey in Safe Mode: Help->Restart with Addons Disabled.
Comment 2 stefan.blumenrath 2012-02-15 07:31:53 PST
OK, you're right with the message, but the problem itself is still existing.
My fastest way to reproduce is a group with many unread postings, then keeping 'n' pressed.
Comment 3 Martin F. 2012-02-15 15:11:45 PST
Can confirm this for x86 and WinXP on 2.8beta and Trunk.

You have to press 'n' key to advance to the next message *faster* than SM marks the current message as read and clears the busy cursor back to normal. For a fast computer/connection at least a triple-hit of the 'n' key might be necessary to trigger this behaviour, but if you keep hammering on 'n' it's reproducible.

Addiotionaly it seems impossible to trigger this behaviour on SM2.7, therefore marking as regression. (don't have a smaller regression-window, sry)
Comment 4 Reinhard Zwirner 2012-02-18 16:24:43 PST
Here, the problem still exists with SM 2.8b3.

With me, it always happens when switching to newsgroup B after having read one or more postings in newsgroup A. It doesn't happen after just lurking without reading. It has nothing to do with fast switching between newsgroups or fast repeating to press 'n' key.
Comment 5 Mike Ritter 2012-02-21 15:09:05 PST
@Philip Chee: disabling extensions fixed not the Problem

WinXP-x86 2.8b3
Comment 6 Mike Ritter 2012-02-22 05:26:31 PST
(In reply to Mike Ritter from comment #5)
> @Philip Chee: disabling extensions fixed not the Problem
> 
> WinXP-x86 2.8b3

Sorry, not read correctly. 
Meant disabling extensions not fixed the cursor-problem.
Comment 7 stefan.blumenrath 2012-02-27 06:37:24 PST
I still see the problem at SM2.8b4 - Maybe it should be listed in 'Known Issues'...
Comment 8 Philip Chee 2012-02-29 13:12:02 PST
> Maybe it should be listed in 'Known Issues'
OK, CC our website expert.
Comment 9 Jens Hatlak (:InvisibleSmiley) 2012-03-05 13:59:48 PST
(In reply to Philip Chee from comment #8)
> > Maybe it should be listed in 'Known Issues'
> OK, CC our website expert.

Hmm, I don't feel this is serious enough. It doesn't seem anything stops working through this. Actually I'm trying to /reduce/ the amount of things we list under Known Issues. Sure, the easiest way would be to fix this issue, but until that happens, what's the impact of this issue on users other than being an annoying?

That said, maybe I'm seeing this, too. I cannot tell for sure, though, since I have tons of add-ons running. I think I could in the past temporarily fix it by compacting all folders.
Comment 10 stefan.blumenrath 2012-03-05 14:24:25 PST
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #9)
> (In reply to Philip Chee from comment #8)
> > > Maybe it should be listed in 'Known Issues'
> > OK, CC our website expert.
> 
> Hmm, I don't feel this is serious enough. It doesn't seem anything stops
> working through this.

From this point of view you're right.

> Actually I'm trying to /reduce/ the amount of things
> we list under Known Issues. Sure, the easiest way would be to fix this
> issue, but until that happens, what's the impact of this issue on users
> other than being an annoying?

I think, someone being annoyed by this bug makes it worth to appear under known issues. YMMV and just my 2cent.

> That said, maybe I'm seeing this, too. I cannot tell for sure, though, since
> I have tons of add-ons running. I think I could in the past temporarily fix
> it by compacting all folders.

compact folder doesn't stop "my" busy-cursor... I've seen this by now under:
W764 and XP with and without addons
Xubuntu with a clean profile, only subscribed to de.test
Comment 11 Martin F. 2012-03-05 16:28:27 PST
I wonder what's meant with "in the past", this is a regression which has not existed in the releases until and including 2.7.x it seems. This behaviour was introduced in SM2.8 (which would mean it should be fixed before relaeasing 2.8, but I guess that's "out of sight"...)
Comment 12 Jens Hatlak (:InvisibleSmiley) 2012-03-06 00:09:54 PST
(In reply to commander_keen from comment #11)
> I wonder what's meant with "in the past"

I was looking back from the point in time when I wrote the comment, because I had no busy cursor at that moment. I was not referring to SM versions. Sorry for the confusion.
Comment 13 Reinhard Zwirner 2012-03-07 14:08:13 PST
SM 2.8b5: Problem still exists :-(
Comment 14 Jens Hatlak (:InvisibleSmiley) 2012-03-07 14:16:23 PST
(In reply to Reinhard Zwirner from comment #13)
> SM 2.8b5: Problem still exists :-(

Well I guess 2.8b6 will be tagged soon and released tomorrow, and might be the last 2.8 beta, so the bug will probably be in 2.8 final.

Did anyone check whether TB is affected, too? If the bug really is in core MailNews code, searching for and possibly helping to improve a corresponding TB or MailNews Core bug might speed things up since SM devs are unlikely to fix core MailNews bugs.
Comment 15 stefan.blumenrath 2012-03-07 15:00:30 PST
OK, just checked out TB11b4 - it's not affected. So I think it isn't a core bug?
Comment 16 Reinhard Zwirner 2012-03-09 16:53:10 PST
SM 2.8b6 Still the same ...
Comment 17 Reinhard Zwirner 2012-03-14 10:26:35 PDT
Still SM 2.8b6 - but that annoying permanent busy cursor is gone :-). Let's hope it will stay away (fingers crossed).

Maybe it has something to do with the latest Microsoft patchday (yesterday).
Comment 18 Reinhard Zwirner 2012-03-14 10:44:57 PDT
Hmm - it's back again :-(. Unfortunately, I can't say when exactly it came back.
Comment 19 James Skinner 2012-03-16 06:39:19 PDT
I have also noticed that using SM 2.8 and doing a Ctrl+Shift+C on a newsgroup to mark all read will cause the cursor to begin being active.
Comment 20 Ruediger Lahl 2012-03-16 06:53:41 PDT
My last good was 20111116030726
My first bad was 20111127003001

Wide window, but better than nothing, I think.
Comment 21 Ruediger Lahl 2012-03-16 10:08:05 PDT
(In reply to Ruediger Lahl from comment #20)

> Wide window, but better than nothing, I think.

'hafi' from MID 4F634D27.908@hfigge.myfqdn.de has an smaller window:
Last good 20111120224000
first bad 20111121222700
both builds self-compiled
Comment 22 Jens Hatlak (:InvisibleSmiley) 2012-03-16 10:50:31 PDT
(In reply to Ruediger Lahl from comment #21)
> Last good 20111120224000
> first bad 20111121222700

According to hg pushlog (assuming I used it correctly), there's just a single changeset in that time frame:

http://hg.mozilla.org/comm-central/rev/e57a9c880238
"Bug 226890 - Thunderbird doesn't handle news URIs properly, part 10: Make command-line news handling work."

Joshua, since you're the author of that code, do you have an idea what's going on, and maybe also why TB is not affected (assuming comment 15 is right)?
Comment 23 Jens Hatlak (:InvisibleSmiley) 2012-03-16 11:34:42 PDT
*** Bug 736505 has been marked as a duplicate of this bug. ***
Comment 24 Alfred Peters 2012-03-16 11:41:46 PDT
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #22)
> going on, and maybe also why TB is not affected (assuming comment 15 is
> right)?

No, that isn't correct. I can confirm that TB Trunk is also effected.

My regression window for TB is:
Last good: 20111118144020
First bad: 20111125152540
Comment 25 Jens Hatlak (:InvisibleSmiley) 2012-03-16 12:33:40 PDT
(In reply to Alfred Peters from comment #24)
> (In reply to Jens Hatlak (:InvisibleSmiley) from comment #22)
> > going on, and maybe also why TB is not affected (assuming comment 15 is
> > right)?
> 
> No, that isn't correct. I can confirm that TB Trunk is also effected.

OK then, if at least one other TB user confirms this, I'll move this bug to MailNews Core (unless someone like Joshua does it before I do of course). I'll also relnote this now (for SM 2.8 and later, until fixed).
Comment 26 NoOp 2012-03-16 13:29:30 PDT
Definately a distraction as I use newsgroups extensively:
Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20120312 Firefox/11.0 SeaMonkey/2.8
 Multiple confirmations (me too's) on the SeaMonkey support newsgroup.
Downloading the update for Thunderbird & will check to see if I get the same on TB 11.
Any chance of a possible workaround for this?
Comment 27 NoOp 2012-03-16 13:42:34 PDT
I've not been able to reproduce (yet) on:
Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20120312 Thunderbird/11.0
Comment 28 Hartmut Figge 2012-03-16 14:20:55 PDT
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #22)

> http://hg.mozilla.org/comm-central/rev/e57a9c880238

It would be nice to be able to back that one out, but unhappily

hafi@i5_64 ~/hg-moz/src $ patch --dry-run -p1 -R < ~/hg-moz/p1
patching file mail/components/nsMailDefaultHandler.js
patching file mailnews/base/util/nsMsgProtocol.cpp
patching file mailnews/news/src/nsNntpIncomingServer.cpp
Hunk #1 succeeded at 767 (offset -2 lines).
patching file mailnews/news/src/nsNntpService.cpp
Hunk #2 FAILED at 1045.
Hunk #3 FAILED at 1711.
Comment 29 Alfred Peters 2012-03-17 11:56:26 PDT
(In reply to Alfred Peters from comment #24)

> No, that isn't correct. I can confirm that TB Trunk is also effected.

Ok, in a new profile I also have no bug.

So I checked my config and found that the pref ui.use_activity_cursor was set to true. When I reset it to the TB default value (false), the bug is gone.
Comment 30 Jens Hatlak (:InvisibleSmiley) 2012-03-17 12:03:15 PDT
(In reply to Alfred Peters from comment #29)
> (In reply to Alfred Peters from comment #24)
> 
> > No, that isn't correct. I can confirm that TB Trunk is also effected.
> 
> Ok, in a new profile I also have no bug.
> 
> So I checked my config and found that the pref ui.use_activity_cursor was
> set to true. When I reset it to the TB default value (false), the bug is
> gone.

Can you (and anyone else using TB and reading this) please re-check how a fresh TB profile behaves with ui.use_activity_cursor = true? Thanks. If you can provide clear steps to reproduce, even better!
Comment 31 Alfred Peters 2012-03-17 12:28:04 PDT
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #30)

> Can you (and anyone else using TB and reading this) please re-check how a
> fresh TB profile behaves with ui.use_activity_cursor = true? Thanks.

Yes, I have the bug in a new profile with that pref set.

>  If you
> can provide clear steps to reproduce, even better!

Steps to reproduce with TB:

1. Subscribe to at last 2 newsgroups (download article)
2. Configure ui.use_activity_cursor = true
3. Select "Group A"
4. Select an article in the Threadpane
5. Select a different group "Group B"

Messagepane is now empty and the busy-cursor occurs when the mouse-cursor is over the folder- or threadpane.
Comment 32 stefan.blumenrath 2012-03-17 12:46:43 PDT
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #30)

> Can you (and anyone else using TB and reading this) please re-check how a
> fresh TB profile behaves with ui.use_activity_cursor = true? Thanks. If you
> can provide clear steps to reproduce, even better!

done. I see the busy-cursor on TB11beta, W7/64
New profile, only newsgroup-account,
1. subscribe de.test
2. change ui.use_activity_cursor to true
3. select any message
4. press and hold 'n' for a few seconds
5. done.
Comment 33 Ruediger Lahl 2012-03-17 12:54:17 PDT
In SeaMonkey 'ui.use_activity_cursor' is per default set on 'true' and in Thunderbird and Firefox per default on 'false'.
Comment 34 mploug 2012-03-18 04:15:22 PDT
Thank you, ui.use_activity_cursor = false seems to solve the problem.
Comment 35 NoOp 2012-03-18 10:12:16 PDT
Re: ui.use_activity_cursor
Setting to false in SeaMonkey 2.8 seems to have solved the problem for me. Thanks.

Also tested with Thunderbird 11.0: 
Set 'ui.use_activity_cursor' to true, opened a second newsgroup in a new tab[1] & sure enough the wait cursor appears. Set 'ui.use_activity_cursor' back to false & the problem goes away.

[1] I've found the easiest way to trigger the issue when opening SeaMonkey/Thunderbird is to open a second newsgroup in a new tab. The wait cursor will appear every time (with 'us.use_activity_cursor' set to true).
Comment 36 Philip Chee 2012-03-18 14:00:48 PDT
This appears to be fallout from http://hg.mozilla.org/comm-central/rev/29fd2b00d1ad
c.f. Bug 537015 - Restore the spinner that was removed in bug 481359
CC Neil

Also see:
Bug 482985 - Loading/busy/spinning mouse indicator/pointer/icon missing
Bug 659573 - When enabled ui.use_activity_cursor - don't show busy indicator over toolbars and menu, only when mouse is over page content.
Comment 37 neil@parkwaycc.co.uk 2012-03-18 14:31:25 PDT
(In reply to Philip Chee from comment #36)
> This appears to be fallout from
If this is fallout (i.e. it wasn't broken before bug 481359) I think it's more likely to be fallout from Thunderbird developers not correctly resetting something and not noticing a problem because their UI doesn't care.
Comment 38 NoOp 2012-04-26 12:49:19 PDT
I did the same tests as my comment #35 with SeaMonkey 2.9 and Thunderbird 12: the results are the same. The problem most likely isn't noticed in Thunderbird due ui.use_activity_cursor;false being set as default (see comment #33). You have to manually change it to 'true' in order to reproduce. 

SeaMonkey ui.use_activity_cursor is set to 'true' by default. Is there any reason why this is different than the default for Firefox and Thunderbird?
Comment 39 Jens Hatlak (:InvisibleSmiley) 2012-04-26 13:17:19 PDT
(In reply to NoOp from comment #38)
> SeaMonkey ui.use_activity_cursor is set to 'true' by default. Is there any
> reason why this is different than the default for Firefox and Thunderbird?

The reasoning of FF's UX guys is explained in bug 482985 comment 113. That comment/decision was the reason why the default of this pref is false for all Gecko-based applications that do not override it. TB doesn't override the pref, but we do (since bug 537015, on all platforms but Mac).
Comment 40 NoOp 2012-04-26 13:21:39 PDT
Got it - thanks Jens.
Comment 41 Mark Banner (:standard8) (afk until 26th July) 2012-06-20 03:23:40 PDT
Removing relnote keyword from bugs that are no longer significant or not needing to be mentioned in the release notes.
Comment 42 Jens Hatlak (:InvisibleSmiley) 2012-06-20 04:30:35 PDT
(In reply to Mark Banner (:standard8) from comment #41)
> Removing relnote keyword from bugs that are no longer significant or not
> needing to be mentioned in the release notes.

I take it that "relnote" on MailNews Core bugs strictly refers to TB then (since this bug still *is* an issue for SM). I guess I'll eventually have to define a SM-specific whiteboard relnote tag...
Comment 43 Mark Banner (:standard8) (afk until 26th July) 2012-06-22 03:18:08 PDT
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #42)
> (In reply to Mark Banner (:standard8) from comment #41)
> > Removing relnote keyword from bugs that are no longer significant or not
> > needing to be mentioned in the release notes.
> 
> I take it that "relnote" on MailNews Core bugs strictly refers to TB then
> (since this bug still *is* an issue for SM). I guess I'll eventually have to
> define a SM-specific whiteboard relnote tag...

Ok, lets go for relnote with an additional whiteboard note.
Comment 44 martin11 2012-06-26 17:38:20 PDT
Created attachment 636950 [details]
BUG
Comment 45 Ed 2012-08-05 10:44:10 PDT
It seems that this change of cursor from pointer to hourglass has gotten worse in the SM 2.11 release.  I didn't notice it too often previously, but it occurs most of the time now.  Configuration:

User Agent: Mozilla/5.0 (Windows NT 5.1; WOW64; rv:14.0) Gecko/20120715 Firefox/14.0.1 SeaMonkey/2.11

Extensions (enabled: 7)
* DownloadHelper 4.9.9 (http://www.downloadhelper.net)
* Enigmail 1.4.3 (http://enigmail.mozdev.org/)
* FireFTP 2.0.4 (http://fireftp.mozdev.org)
* Flash and Video Download 1.13 (www.fnvfox.com)
* JavaScript Debugger 0.9.89 (http://www.hacksrus.com/~ginda/venkman/)
* PrefBar 6.1.0 (http://prefbar.tuxfamily.org/)
* Quote Colors 0.3 (http://quotecolors.mozdev.org/)
Comment 46 oldrah 2012-09-06 11:15:31 PDT
Still present in SeaMonkey 2.12. Something I don't see in the above comments that is the easiest way I've found to circumvent it: hit the "Stop" button on the toolbar.
Dick Hoffman
Comment 47 Hartmut Figge 2012-12-23 03:01:16 PST
Created attachment 695294 [details] [diff] [review]
fix try1 [Checkin: Comment 52]

try1 backs out part of the in Comment 22 mentioned suspicious changeset.
Comment 48 Hartmut Figge 2013-01-15 11:24:52 PST
FWIW, for three weeks now i have applied the patch try1 to my daily builds and have not seen the bug since.
Comment 49 Hartmut Figge 2013-03-29 14:00:31 PDT
I am still applying try1 to my daily builds and do not see the bug. Since it was introduced by a checkin of Joshua, try1 should be reviewed by him.

Well, no response or other comments. I am feeling that i have done what can be expected from a user, so the further progress is up to others.
Comment 50 Alfred Peters 2013-03-30 10:35:35 PDT
(In reply to Hartmut Figge from comment #47)
> Created attachment 695294 [details] [diff] [review]
> fix try1

Yes, this fixes the problem also on TB (with 'ui.use_activity_cursor = true').
Comment 51 Hartmut Figge 2013-06-22 22:29:58 PDT
After the r+, could someone please take over? try1 is not a proper hg patch and i am not familiar with the required next steps.
Comment 52 Jens Hatlak (:InvisibleSmiley) 2013-06-22 23:47:48 PDT
Comment on attachment 695294 [details] [diff] [review]
fix try1 [Checkin: Comment 52]

https://hg.mozilla.org/comm-central/rev/89ca38497a74

Note You need to log in before you can comment on or make changes to this bug.