Outliner painting bug using up/down keys to change selection

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
normal
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: fenella, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({pp})

Trunk
mozilla0.9.1
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

(Reporter)

Description

17 years ago
Mac (2001-03-19-12 mtrunk)
1. Select Inbox folder, press on the arrow down key
Actual result: when it comes down to the second half of the message, it
high-lights 7 message threads
Expected result: Only one selection should occurs
2. press on the arrow up key
Actual result: It de-select the second half of the thread and then multiple
select the upper half of the threads.

This occurs on Mac only

Updated

17 years ago
QA Contact: esther → nbaca

Comment 1

17 years ago
So, you get a mis-selection?   Is this just a refresh problem?  Or if you were 
to delete at that point, all selected items get deleted?
Keywords: pp
(Reporter)

Comment 2

17 years ago
I am not sure.
Using the downward arrow key, if I press Delete, the last message got deleteed.
Using the upward arrow key, if I press Delete, all selected messages got deleted.

Comment 3

17 years ago
Build 2001-03-28-04: Mac 9.04
This problem is still occuring. Multiple selection seems to start when the 
message right above the horizontal splitter (b/n the thread and message pane) 
is selected.

Updated

17 years ago
Keywords: nsbeta1

Updated

17 years ago
Priority: -- → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9

Updated

17 years ago
Target Milestone: mozilla0.9 → mozilla0.9.1

Comment 4

17 years ago
So, this looks like it's a painting problem in the outliner because when I cause
a repaint by dragging another window over it, the problem goes away.  I'm going
to reassign to hyatt, but if it's something we're doing in mailnews, let us know.

It's pretty easy to reproduce. I just select the top message in flat view and
start arrowing up. All messages appear to be selected (even though they really
aren't based on the fact that operations only work on one message).
Assignee: sspitzer → hyatt
Keywords: mailtrack

Comment 5

17 years ago
--> dr.
Assignee: hyatt → dr

Comment 6

17 years ago
> Using the downward arrow key, if I press Delete, the last message got
> deleteed. Using the upward arrow key, if I press Delete, all selected
> messages got deleted.

That's not right. Only the "real" selection gets deleted as far as I can see.
It's just a painting problem, as putterman says. Accepting (sooo, let's see if I
can work on Mac :)
Status: NEW → ASSIGNED
Component: Mail Window Front End → XP Toolkit/Widgets: Trees
Priority: P2 → P3
Product: MailNews → Browser

Updated

17 years ago
Summary: Multiple selections(high-lights)using upward or downward keys → Outliner painting bug using up/down keys to change selection

Comment 7

17 years ago
->pinkerton (hyatt sez, "i didn't notice it was mac-only")
Assignee: dr → pinkerton
Status: ASSIGNED → NEW
(Assignee)

Comment 8

17 years ago
excuse me? why is this mine (is it because i happen to have a mac?). that's not a 
very good reason.
Assignee: pinkerton → hyatt

Comment 9

17 years ago
*** Bug 78459 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
--> trudelle.  This can be given to someone else.  
Assignee: hyatt → trudelle
Target Milestone: mozilla0.9.1 → ---
(Assignee)

Comment 11

17 years ago
taking
Assignee: trudelle → pinkerton

Comment 12

17 years ago
pink: fwiw, hyatt mentioned to me that this is more or less the exact same mac
painting bug as was in the tree widget.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1

Updated

17 years ago
Blocks: 75643
(Assignee)

Comment 13

17 years ago
with a build from 5/16/01, i can't reproduce this at all. no matter what i do 
with the up or down arrow keys in the thread pane, i only see one message 
selected.

i tried both modern and classic, message pane hidden and visible. tried both my 
powerbook and desktop.

-->WFM, i guess.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 14

17 years ago
Build 2001-05-16-04: Mac 9.04
Verified Worksforme.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: nbaca → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.