scrolling bookmarks with arrow keys very slow

VERIFIED DUPLICATE of bug 52149

Status

SeaMonkey
Bookmarks & History
VERIFIED DUPLICATE of bug 52149
17 years ago
13 years ago

People

(Reporter: Brad Nixon, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Overview Description: 
If you move through the bookmark manager list with the up/down arrow keys really
fast, the highlight of the selection can't keep up, it's obvious and painfully
slow. Maybe it would be an idea to change the bookmark manager to use the
outiner (which is very fast). (In fact the tree control should probably be
replaced everywhere with the new outliner but that would have to be another bug :))

Steps to Reproduce:
1)Open the bookmark manager, assuming you have an average-sized list (10-15 main
folders).
2)Make sure the first item in the list is highlighted, then press the down arrow
a few times in quick succession.

Result:
The highlight can't keep up with each key press, it usually just jumps to the
last one item you scrolled to.

Expected:
The highlight should be able to keep up with each keypress.

Tested on Moz 0.8, also on 20 March 2001 nightlies, Win2000.

Comment 1

17 years ago
confirming, I see this on all platforms with 2001032108 builds. I struggled with this while
testing bookmarks performance. see the results at:
http://www.mozilla.org/quality/perf/index.html
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Keywords: nsbeta1

Updated

17 years ago
Keywords: perf

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1-

Comment 2

17 years ago
Dupe of http://bugzilla.mozilla.org/show_bug.cgi?id=52149  ??

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 52149 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.