If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

multiple hyphenation errors in "Bundespräsident Wulff"

NEW
Unassigned

Status

()

Core
Layout: Text
6 years ago
4 years ago

People

(Reporter: Stefan, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 597611 [details]
testcase bpw.html

User Agent:  
Build ID: 20120216001128

Steps to reproduce:

1. Open testcase
2. Resize textarea. Observe hyphenations.


Actual results:

Bun|des|prä|si|dent Wul|ff. If the textarea is very small I see the "hyphenation"

Bun
des
präsi-
...


Expected results:

Bun|des|prä|si|dent Wulff
Attachment #597611 - Attachment mime type: text/plain → text/html
(Reporter)

Updated

6 years ago
OS: Other → Linux
Hardware: Other → x86
It looks like there are actually two issues here:
a) In a very narrow textarea, we fail to draw the hyphen in some cases, even though we're finding suitable breakpoints;
b) The inappropriate hyphen position "Wul-ff".

(a) is presumably a general problem of the hyphenation/text-layout code, while (b) is a specific flaw in the German hyphenation rules.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

4 years ago
Just checked it with 27.0a1 (2013-11-13): Neither (a) nor (b) works. At least not for me. Do you need screenshots?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

4 years ago
Created attachment 8336977 [details]
(a).png
(Reporter)

Comment 4

4 years ago
Created attachment 8336979 [details]
(b).png

Comment 5

4 years ago
Okay, I see the point in b) (Wul|ff), but what is wrong in a) ?
Flags: needinfo?(kdevel)
(Reporter)

Comment 6

4 years ago
(In reply to sjw from comment #5)
> what is wrong in a) ?

Let me quote from comment #1 "we fail to draw the hyphen in some cases, even though we're finding suitable breakpoints".
Flags: needinfo?(kdevel)

Comment 7

4 years ago
Oh, I see. Sorry.
Status: REOPENED → NEW
Component: Untriaged → Layout: Text
Product: Firefox → Core
Blocks: 656750
You need to log in before you can comment on or make changes to this bug.